blob: 54b59ccb79f277ca02a49249e1902a36267ee9d2 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001# This recipe is intended as a 'simpler' replacement for packagegroup-base.
2# Please communicate your use cases and suggestions to the mailinglist(s)
3
4SUMMARY = "Basic task to get a device online"
5LICENSE = "MIT"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05007
8PR = "r13"
9
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11inherit packagegroup
Patrick Williamsb48b7b42016-08-17 15:04:38 -050012
13# Poke extra recomendations into the list using your machine.conf
14#
15MACHINE_EXTRA_RRECOMMENDS ?= ""
16
17#
18# Select between dropbear and openssh
19# Set TASK_BASIC_SSHDAEMON = "openssh-sshd openssh-sftp openssh-sftp-server" in your DISTRO config to get openssh(d)
20#
21TASK_BASIC_SSHDAEMON ?= "dropbear openssh-sftp openssh-sftp-server"
22
23#
Patrick Williamsddad1a12017-02-23 20:36:32 -060024# The section below is designed to match with packagegroup-boot, but doesn't depend on it to allow for more freedom
Patrick Williamsb48b7b42016-08-17 15:04:38 -050025# when writing image recipes.
26# It also avoids the choice between connman/networkmanager/ifupdown since that is an image feature, not a
27# distro feature.
28#
29# Util-linux (u)mount is included because the busybox one can't handle /etc/mtab being symlinked to /proc/mounts
30#
31RDEPENDS_${PN} = "\
32 ${TASK_BASIC_SSHDAEMON} \
33 avahi-daemon avahi-utils \
34"
35
36#
37# The following section is split in 3:
38# 1) Machine features: kernel modules and userspace helpers for those
39# 2) Distro features: packages associated with those
Patrick Williamsddad1a12017-02-23 20:36:32 -060040# 3) Nice to have: packages that are nice to have, but aren't strictly needed
Patrick Williamsb48b7b42016-08-17 15:04:38 -050041#
42RRECOMMENDS_${PN} = "\
43 ${MACHINE_EXTRA_RRECOMMENDS} \
44 ${@bb.utils.contains("MACHINE_FEATURES", "usbhost", "usbutils", "", d)} \
45 ${@bb.utils.contains("MACHINE_FEATURES", "alsa", "alsa-utils-alsamixer", "", d)} \
46 ${@bb.utils.contains("MACHINE_FEATURES", "usbgadget", "kernel-module-g-ether kernel-module-g-serial kernel-module-g-mass-storage", "", d)} \
47 \
Brad Bishop26bdd442019-08-16 17:08:17 -040048 ${@bb.utils.contains("DISTRO_FEATURES", "bluetooth", "bluez5", "", d)} \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050049 ${@bb.utils.contains("DISTRO_FEATURES", "wifi", "iw wpa-supplicant", "", d)} \
50 \
51 tzdata \
52 \
53 cpufrequtils \
54 htop \
55"