blob: 91f94a1aa0797b208a9af5ae73f8e73113fdd285 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "The Perl Database Interface"
2DESCRIPTION = "DBI is a database access Application Programming Interface \
3(API) for the Perl Language. The DBI API Specification defines a set \
4of functions, variables and conventions that provide a consistent \
5database interface independent of the actual database being used. \
6"
7HOMEPAGE = "http://search.cpan.org/dist/DBI/"
8SECTION = "libs"
9LICENSE = "Artistic-1.0 | GPL-1.0+"
Brad Bishop19323692019-04-05 15:28:33 -040010LIC_FILES_CHKSUM = "file://LICENSE;md5=10982c7148e0a012c0fd80534522f5c5"
11
12SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz"
13SRC_URI[md5sum] = "f2ba18b5cea1c8cb322a62be0a847f3d"
14SRC_URI[sha256sum] = "3f2025023a56286cebd15cb495e36ccd9b456c3cc229bf2ce1f69e9ebfc27f5d"
15
16S = "${WORKDIR}/DBI-${PV}"
17
18inherit cpan ptest-perl
19
20do_install_prepend() {
21 # test requires "-T" (taint) command line option
22 rm -rf ${B}/t/pod-coverage.t
23 rm -rf ${B}/t/13taint.t
24 # source of test failure not obvious
25 rm -rf ${B}/t/85gofer.t
26 # unclear why there are several duplicates of tests in tarball
27 rm -rf ${B}/t/z*.t
28}
29
Brad Bishop26bdd442019-08-16 17:08:17 -040030RDEPENDS_${PN}_class-target = " \
31 perl-module-carp \
32 perl-module-exporter \
33 perl-module-exporter-heavy \
34 perl-module-dynaloader \
35 perl-module-io-dir \
36 perl-module-scalar-util \
37 perl-module-universal \
38"
39
40RDEPENDS_${PN}-ptest = " \
41 ${PN} \
42 perl-module-b \
43 perl-module-benchmark \
44 perl-module-cwd \
45 perl-module-data-dumper \
46 perl-module-encode \
47 perl-module-encode-byte \
48 perl-module-encode-encoding \
49 perl-module-file-copy \
50 perl-module-file-path \
51 perl-module-lib \
52 perl-module-perlio \
53 perl-module-perlio-scalar \
54 perl-module-perlio-via \
55 perl-module-sdbm-file \
56 perl-module-storable \
57 perl-module-test-more \
58 perl-module-utf8 \
59 "
60
Brad Bishop19323692019-04-05 15:28:33 -040061BBCLASSEXTEND = "native"