blob: 0ea70b23b54f23a9317c4efa6232852a37137936 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Python GObject bindings"
2HOMEPAGE = "http://www.pygtk.org/"
3SECTION = "devel/python"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
6
Brad Bishop15ae2502019-06-18 21:44:24 -04007GNOMEBASEBUILDCLASS = "meson"
Andrew Geissler1548c072019-02-22 16:03:50 -06008inherit gnomebase gobject-introspection distutils-base upstream-version-is-even
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009
Andrew Geissler1548c072019-02-22 16:03:50 -060010DEPENDS += "python glib-2.0"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011
Andrew Geissler1548c072019-02-22 16:03:50 -060012SRCNAME = "pygobject"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013SRC_URI = " \
14 http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
Brad Bishop26bdd442019-08-16 17:08:17 -040015 file://0001-python-pyobject-fix-install-dir.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016"
17
Brad Bishop26bdd442019-08-16 17:08:17 -040018SRC_URI[md5sum] = "92ffa25351782feb96362f0dace2089f"
19SRC_URI[sha256sum] = "c39ca2a28364b57fa00549c6e836346031e6b886c3ceabfd8ab4b4fed0a83611"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
21S = "${WORKDIR}/${SRCNAME}-${PV}"
22
Brad Bishop15ae2502019-06-18 21:44:24 -040023UNKNOWN_CONFIGURE_WHITELIST = "introspection"
24
Brad Bishop26bdd442019-08-16 17:08:17 -040025PACKAGECONFIG ??= "stagedir"
26
Brad Bishop15ae2502019-06-18 21:44:24 -040027PACKAGECONFIG[cairo] = "-Dpycairo=true,-Dpycairo=false, cairo python-pycairo, python-pycairo"
28PACKAGECONFIG[tests] = "-Dtests=true, -Dtests=false, , "
Brad Bishop26bdd442019-08-16 17:08:17 -040029PACKAGECONFIG[python] = "-Dpython=python3, -Dpython=python2, , "
30PACKAGECONFIG[stagedir] = "-Dstagedir=${PYTHON_SITEPACKAGES_DIR}, -Dstagedir="", , "
Brad Bishop15ae2502019-06-18 21:44:24 -040031
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080032BBCLASSEXTEND = "native"
Brad Bishop26bdd442019-08-16 17:08:17 -040033RDEPENDS_${PN} = "python-pkgutil"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080034RDEPENDS_${PN}_class-native = ""
35
36do_install_append() {
37 # Remove files that clash with python3-pygobject; their content is same
Andrew Geissler1548c072019-02-22 16:03:50 -060038 rm -r ${D}${includedir}/pygobject-3.0/pygobject.h ${D}${libdir}/pkgconfig
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080039}