blob: d414bc683fb976f6526d7d8c6a59b1db9e1c16ee [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "display dialog boxes from shell scripts"
2DESCRIPTION = "Dialog lets you to present a variety of questions \
3or display messages using dialog boxes from a shell \
4script (or any scripting language)."
5HOMEPAGE = "http://invisible-island.net/dialog/"
6SECTION = "console/utils"
7DEPENDS = "ncurses"
8LICENSE = "LGPL-2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
10
11SRC_URI = "ftp://ftp.invisible-island.net/${BPN}/${BP}.tgz \
12 "
Brad Bishop26bdd442019-08-16 17:08:17 -040013SRC_URI[md5sum] = "e9d7f8b5e7b17183b0fb9297c0f57840"
14SRC_URI[sha256sum] = "e5eb0eaaef9cae8c822887bd998e33c2c3b94ebadd37b4f6aba018c0194a2a87"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
16# hardcoded here for use in dialog-static recipe
17S = "${WORKDIR}/dialog-${PV}"
18
19inherit autotools-brokensep pkgconfig
20
21EXTRA_OECONF = "--with-ncurses \
22 --disable-rpath-hack"
23
24do_configure() {
25 gnu-configize --force
26 sed -i 's,${cf_ncuconfig_root}6-config,${cf_ncuconfig_root}-config,g' -i configure
27 sed -i 's,cf_have_ncuconfig=unknown,cf_have_ncuconfig=yes,g' -i configure
28 oe_runconf
29}