blob: 2fdadcbc9f75316cbe09343910c65fd6ae255bb1 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "PAM searchless LDAP authentication module"
2HOMEPAGE = "https://github.com/rmbreak/pam_ldapdb"
3BUGTRACKER = "https://github.com/rmbreak/pam_ldapdb/issues"
4SECTION = "libs"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=41ab94182d94be9bb35e2a8b933f1e7d"
7
8DEPENDS = "libpam openldap"
9
10inherit distro_features_check
11REQUIRED_DISTRO_FEATURES = "pam"
12
Brad Bishop26bdd442019-08-16 17:08:17 -040013SRCREV = "84d7b260f1ae6857ae36e014c9a5968e8aa1cbe8"
14SRC_URI = "git://github.com/rmbreak/pam_ldapdb"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
Brad Bishop26bdd442019-08-16 17:08:17 -040016S = "${WORKDIR}/git"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017
18do_install () {
19 oe_runmake install DESTDIR=${D} PAMDIR=${base_libdir}/security
20}
21
22FILES_${PN} += "${base_libdir}/security/pam_ldapdb.so"