blob: 2dd8322825f9f3d2156b25ae94fdd8d26b43f073 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require recipes-graphics/xorg-app/xorg-app-common.inc
2SUMMARY = "xterm is the standard terminal emulator for the X Window System"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08003DEPENDS = "libxaw xorgproto libxext libxau libxinerama libxpm ncurses"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05004
Brad Bishop26bdd442019-08-16 17:08:17 -04005LIC_FILES_CHKSUM = "file://xterm.h;beginline=3;endline=31;md5=c7faceb872d90115e7c0ad90e90c390d"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006
7SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz"
8
Brad Bishop26bdd442019-08-16 17:08:17 -04009SRC_URI[md5sum] = "05340ef6eabb96826953346c64b35225"
10SRC_URI[sha256sum] = "8b1f5121dbf3690de9d85a3b9329e3357021705dd7c21da192e47542769275be"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050011PACKAGECONFIG ?= ""
12PACKAGECONFIG[xft] = "--enable-freetype,--disable-freetype,libxft fontconfig freetype-native"
13
14EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \
15 --x-libraries=${STAGING_LIBDIR} \
16 FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config \
17 --disable-imake \
18 --disable-rpath-hack \
Brad Bishop26bdd442019-08-16 17:08:17 -040019 --disable-setuid \
20 --with-app-defaults=${datadir}/X11/app-defaults \
21 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050022
23B = "${S}"
24
25do_configure() {
26 gnu-configize --force
27 sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure
28 oe_runconf
29}
30
Brad Bishop316dfdd2018-06-25 12:45:53 -040031# busybox can supply resize too
32inherit update-alternatives
33
34ALTERNATIVE_${PN} = "resize"