blob: cc07dcb06ec15eedcf9c4c4e2631b19d53f8b253 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "Satyr is a collection of low-level algorithms for program \
2failure processing, analysis, and reporting supporting kernel space, user \
3space, Python, and Java programs"
4
5HOMEPAGE = "https://github.com/abrt/satyr"
6LICENSE = "GPLv2"
7
8inherit autotools-brokensep python3native pkgconfig
9
10SRC_URI = "git://github.com/abrt/satyr.git \
11 file://0002-fix-compile-failure-against-musl-C-library.patch \
12"
13SRCREV = "dff1b877d42bf2153f8f090905d9cc8fb333bf1e"
14S = "${WORKDIR}/git"
15
16LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
17
18DEPENDS += " \
19 gdb \
20"
21
Brad Bishop26bdd442019-08-16 17:08:17 -040022PACKAGES += "python3-${BPN}"
23FILES_python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
Brad Bishop19323692019-04-05 15:28:33 -040024
25PACKAGECONFIG ??= "python3 rpm"
26PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"
27PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
28PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm"
29
30do_configure_prepend() {
31 ${S}/gen-version
32}