blob: b7e2493c32ecf6cde1a8a2598bd21634ae8de6e6 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "GUI tool for storage configuration using blivet library"
2HOMEPAGE = "https://github.com/rhinstaller/blivet-gui"
3LICENSE = "GPLv2+"
4SECTION = "devel/python"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8S = "${WORKDIR}/git"
9B = "${S}"
10
11SRCREV = "67ec0b7a0e065ba24ab87963409bfb21b2aac6dd"
12SRC_URI = "git://github.com/rhinstaller/blivet-gui;branch=master \
Brad Bishop26bdd442019-08-16 17:08:17 -040013 file://0001-Fix-return-type-of-BlivetUtils.get_disks-1658893.patch \
Brad Bishop19323692019-04-05 15:28:33 -040014"
15
16inherit distro_features_check
17REQUIRED_DISTRO_FEATURES = "x11 systemd"
18
19inherit setuptools3 python3native
20
21RDEPENDS_${PN} = "python3-pygobject python3 \
22 python3-blivet gtk+3 \
23 python3-pid libreport \
24"
25
26FILES_${PN} += " \
27 ${datadir}/* \
28 "