blob: 160bc16d0a1cccb112c0062004ace9d4e42de564 [file] [log] [blame]
Patrick Williams8b8bc412016-08-17 15:02:23 -05001DESCRIPTION = "Commented config.txt file for the Raspberry Pi. \
2 The Raspberry Pi config.txt file is read by the GPU before \
3 the ARM core is initialised. It can be used to set various \
4 system configuration parameters."
5LICENSE = "MIT"
Brad Bishopf27bdd52018-05-07 15:42:31 +02006LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
Patrick Williams8b8bc412016-08-17 15:02:23 -05007
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008COMPATIBLE_MACHINE = "^rpi$"
Patrick Williams8b8bc412016-08-17 15:02:23 -05009
10SRCREV = "648ffc470824c43eb0d16c485f4c24816b32cd6f"
11SRC_URI = "git://github.com/Evilpaul/RPi-config.git;protocol=git;branch=master \
12 "
13
14S = "${WORKDIR}/git"
15
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -060016PR = "r5"
Patrick Williams8b8bc412016-08-17 15:02:23 -050017
Brad Bishop316dfdd2018-06-25 12:45:53 -040018INHIBIT_DEFAULT_DEPS = "1"
19
Patrick Williams8b8bc412016-08-17 15:02:23 -050020PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}"
21PITFT22="${@bb.utils.contains("MACHINE_FEATURES", "pitft22", "1", "0", d)}"
22PITFT28r="${@bb.utils.contains("MACHINE_FEATURES", "pitft28r", "1", "0", d)}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023PITFT35r="${@bb.utils.contains("MACHINE_FEATURES", "pitft35r", "1", "0", d)}"
Patrick Williams8b8bc412016-08-17 15:02:23 -050024
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -060025VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026VC4DTBO ?= "vc4-kms-v3d"
Brad Bishop316dfdd2018-06-25 12:45:53 -040027
28inherit deploy nopackages
Patrick Williams8b8bc412016-08-17 15:02:23 -050029
30do_deploy() {
31 install -d ${DEPLOYDIR}/bcm2835-bootfiles
32
33 cp ${S}/config.txt ${DEPLOYDIR}/bcm2835-bootfiles/
34
35 if [ -n "${KEY_DECODE_MPG2}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040036 sed -i '/#decode_MPG2=/ c\decode_MPG2=${KEY_DECODE_MPG2}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050037 fi
38 if [ -n "${KEY_DECODE_WVC1}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040039 sed -i '/#decode_WVC1=/ c\decode_WVC1=${KEY_DECODE_WVC1}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050040 fi
41 if [ -n "${DISABLE_OVERSCAN}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040042 sed -i '/#disable_overscan=/ c\disable_overscan=${DISABLE_OVERSCAN}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050043 fi
Brad Bishop26bdd442019-08-16 17:08:17 -040044 if [ "${DISABLE_SPLASH}" = "1" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040045 sed -i '/#disable_splash=/ c\disable_splash=${DISABLE_SPLASH}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
46 fi
47
48 # Set overclocking options
Patrick Williams8b8bc412016-08-17 15:02:23 -050049 if [ -n "${ARM_FREQ}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040050 sed -i '/#arm_freq=/ c\arm_freq=${ARM_FREQ}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
51 fi
52 if [ -n "${GPU_FREQ}" ]; then
53 sed -i '/#gpu_freq=/ c\gpu_freq=${GPU_FREQ}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050054 fi
55 if [ -n "${CORE_FREQ}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040056 sed -i '/#core_freq=/ c\core_freq=${CORE_FREQ}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050057 fi
58 if [ -n "${SDRAM_FREQ}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040059 sed -i '/#sdram_freq=/ c\sdram_freq=${SDRAM_FREQ}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050060 fi
61 if [ -n "${OVER_VOLTAGE}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040062 sed -i '/#over_voltage=/ c\over_voltage=${OVER_VOLTAGE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050063 fi
64
65 # GPU memory
66 if [ -n "${GPU_MEM}" ]; then
67 sed -i '/#gpu_mem=/ c\gpu_mem=${GPU_MEM}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
68 fi
69 if [ -n "${GPU_MEM_256}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040070 sed -i '/#gpu_mem_256=/ c\gpu_mem_256=${GPU_MEM_256}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050071 fi
72 if [ -n "${GPU_MEM_512}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040073 sed -i '/#gpu_mem_512=/ c\gpu_mem_512=${GPU_MEM_512}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050074 fi
75 if [ -n "${GPU_MEM_1024}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040076 sed -i '/#gpu_mem_1024=/ c\gpu_mem_1024=${GPU_MEM_1024}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
77 fi
78
79 # Set boot delay
80 if [ -n "${BOOT_DELAY}" ]; then
81 sed -i '/#boot_delay=/ c\boot_delay=${BOOT_DELAY}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
82 fi
83 if [ -n "${BOOT_DELAY_MS}" ]; then
84 sed -i '/#boot_delay_ms=/ c\boot_delay_ms=${BOOT_DELAY_MS}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
85 fi
86
87 # Set HDMI and composite video options
88 if [ -n "${HDMI_FORCE_HOTPLUG}" ]; then
89 sed -i '/#hdmi_force_hotplug=/ c\hdmi_force_hotplug=${HDMI_FORCE_HOTPLUG}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
90 fi
91 if [ -n "${HDMI_DRIVE}" ]; then
92 sed -i '/#hdmi_drive=/ c\hdmi_drive=${HDMI_DRIVE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
93 fi
94 if [ -n "${HDMI_GROUP}" ]; then
95 sed -i '/#hdmi_group=/ c\hdmi_group=${HDMI_GROUP}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
96 fi
97 if [ -n "${HDMI_MODE}" ]; then
98 sed -i '/#hdmi_mode=/ c\hdmi_mode=${HDMI_MODE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
99 fi
100 if [ -n "${CONFIG_HDMI_BOOST}" ]; then
101 sed -i '/#config_hdmi_boost=/ c\config_hdmi_boost=${CONFIG_HDMI_BOOST}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
102 fi
103 if [ -n "${SDTV_MODE}" ]; then
104 sed -i '/#sdtv_mode=/ c\sdtv_mode=${SDTV_MODE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
105 fi
106 if [ -n "${SDTV_ASPECT}" ]; then
107 sed -i '/#sdtv_aspect=/ c\sdtv_aspect=${SDTV_ASPECT}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
108 fi
109 if [ -n "${DISPLAY_ROTATE}" ]; then
110 sed -i '/#display_rotate=/ c\display_rotate=${DISPLAY_ROTATE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -0500111 fi
112
113 # Video camera support
Brad Bishop26bdd442019-08-16 17:08:17 -0400114 if [ "${VIDEO_CAMERA}" = "1" ]; then
Patrick Williams8b8bc412016-08-17 15:02:23 -0500115 echo "# Enable video camera" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
116 echo "start_x=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
117 fi
118
119 # Offline compositing support
Brad Bishop26bdd442019-08-16 17:08:17 -0400120 if [ "${DISPMANX_OFFLINE}" = "1" ]; then
Patrick Williams8b8bc412016-08-17 15:02:23 -0500121 echo "# Enable offline compositing" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
122 echo "dispmanx_offline=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
123 fi
124
125 # SPI bus support
Brad Bishop26bdd442019-08-16 17:08:17 -0400126 if [ "${ENABLE_SPI_BUS}" = "1" ] || [ "${PITFT}" = "1" ]; then
Patrick Williams8b8bc412016-08-17 15:02:23 -0500127 echo "# Enable SPI bus" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
128 echo "dtparam=spi=on" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
129 fi
130
Brad Bishop316dfdd2018-06-25 12:45:53 -0400131 # I2C support
Brad Bishop26bdd442019-08-16 17:08:17 -0400132 if [ "${ENABLE_I2C}" = "1" ] || [ "${PITFT}" = "1" ]; then
Patrick Williams8b8bc412016-08-17 15:02:23 -0500133 echo "# Enable I2C" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
134 echo "dtparam=i2c1=on" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
135 echo "dtparam=i2c_arm=on" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
136 fi
137
138 # PiTFT22 display support
139 if [ "${PITFT22}" = "1" ]; then
140 echo "# Enable PITFT22 display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
141 echo "dtoverlay=pitft22,rotate=270,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
142 fi
Patrick Williams8b8bc412016-08-17 15:02:23 -0500143 if [ "${PITFT28r}" = "1" ]; then
144 echo "# Enable PITFT28r display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
145 echo "dtoverlay=pitft28-resistive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
146 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500147 if [ "${PITFT35r}" = "1" ]; then
148 echo "# Enable PITFT35r display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
149 echo "dtoverlay=pitft35-resistive,rotate=90,speed=42000000,fps=20" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
150 fi
151
Patrick Williams8b8bc412016-08-17 15:02:23 -0500152 # UART support
153 if [ "${ENABLE_UART}" = "1" ]; then
154 echo "# Enable UART" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
155 echo "enable_uart=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
156 fi
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -0600157
158 # VC4 Graphics support
159 if [ "${VC4GRAPHICS}" = "1" ]; then
160 echo "# Enable VC4 Graphics" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800161 echo "dtoverlay=${VC4DTBO}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -0600162 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500163
164 # Waveshare "C" 1024x600 7" Rev2.1 IPS capacitive touch (http://www.waveshare.com/7inch-HDMI-LCD-C.htm)
165 if [ "${WAVESHARE_1024X600_C_2_1}" = "1" ]; then
166 echo "# Waveshare \"C\" 1024x600 7\" Rev2.1 IPS capacitive touch screen" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
167 echo "max_usb_current=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
168 echo "hdmi_group=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
169 echo "hdmi_mode=87" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
170 echo "hdmi_cvt 1024 600 60 6 0 0 0" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
171 echo "hdmi_drive=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
172 fi
Brad Bishop316dfdd2018-06-25 12:45:53 -0400173
174 # DWC2 USB peripheral support
175 if [ "${ENABLE_DWC2_PERIPHERAL}" = "1" ]; then
176 echo "# Enable USB peripheral mode" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
177 echo "dtoverlay=dwc2,dr_mode=peripheral" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
178 fi
Brad Bishopf27bdd52018-05-07 15:42:31 +0200179
180 # AT86RF23X support
181 if [ "${ENABLE_AT86RF}" = "1" ]; then
182 echo "# Enable AT86RF23X" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
183 echo "dtoverlay=at86rf233,speed=3000000" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
184 fi
185
Brad Bishop19323692019-04-05 15:28:33 -0400186 # ENABLE CAN
187 if [ "${ENABLE_CAN}" = "1" ]; then
188 echo "# Enable CAN" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
189 echo "dtoverlay=mcp2515-can0,oscillator=16000000,interrupt=25" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
190 fi
191
Brad Bishop316dfdd2018-06-25 12:45:53 -0400192 # Append extra config if the user has provided any
Andrew Geissler1c349142019-02-19 19:49:56 -0600193 printf "${RPI_EXTRA_CONFIG}\n" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Brad Bishop26bdd442019-08-16 17:08:17 -0400194
195 # Handle setup with armstub file
196 if [ "${@bb.utils.contains("MACHINE_FEATURES", "armstub", "1", "0", d)}" = "1" ]; then
197 echo "\n# ARM stub configuration" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
198 echo "armstub=${ARMSTUB}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
199 case "${ARMSTUB}" in
200 *-gic.bin)
201 echo "enable_gic=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
202 ;;
203 esac
204 fi
Patrick Williams8b8bc412016-08-17 15:02:23 -0500205}
206
Brad Bishop3a5fbf52017-12-04 02:17:07 -0500207do_deploy_append_raspberrypi3-64() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500208 echo "# have a properly sized image" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
209 echo "disable_overscan=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
210
211 echo "# Enable audio (loads snd_bcm2835)" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
212 echo "dtparam=audio=on" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Brad Bishop3a5fbf52017-12-04 02:17:07 -0500213}
214
Brad Bishop316dfdd2018-06-25 12:45:53 -0400215addtask deploy before do_build after do_install
Patrick Williams8b8bc412016-08-17 15:02:23 -0500216do_deploy[dirs] += "${DEPLOYDIR}/bcm2835-bootfiles"
217
218PACKAGE_ARCH = "${MACHINE_ARCH}"