blob: 5ea00142a6c581f3e77b62e33589fc5efb540195 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Python module to control the Raspberry Pi Sense HAT used in the Astro Pi mission"
2HOMEPAGE = "https://github.com/RPi-Distro/python-sense-hat"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=d80fe312e1ff5fbd97369b093bf21cda"
6
Brad Bishop26bdd442019-08-16 17:08:17 -04007inherit setuptools3 pypi
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008
9PYPI_PACKAGE = "sense-hat"
10
11SRC_URI[md5sum] = "69929250cb72349a8a82edf2584b1d83"
12SRC_URI[sha256sum] = "f000998d042d96ed722d459312e1bebd0107f9f3015cd34b3e4fabcab9c800af"
13
14DEPENDS += " \
15 jpeg \
16 zlib \
17 freetype \
18 "
19
20RDEPENDS_${PN} += " \
Brad Bishop26bdd442019-08-16 17:08:17 -040021 ${PYTHON_PN}-numpy \
22 ${PYTHON_PN}-rtimu \
23 ${PYTHON_PN}-imaging \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024 "