blob: 64195f9e1503242f5dbf39cdcf8afaccd9363ad8 [file] [log] [blame]
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -05001SUMMARY = "Miscellaneous OpenBMC functions"
2HOMEPAGE = "https://github.com/openbmc/phosphor-misc"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Ed Tanous9936f862022-09-19 09:13:20 -07005DEPENDS = "systemd"
Andrew Geissler606d9252022-12-12 09:50:22 -06006SRCREV = "37c76da7c277f3531f35ec726ac690e53ab4915a"
Ed Tanous9936f862022-09-19 09:13:20 -07007PACKAGECONFIG ??= " \
8 first-boot-set-hostname \
9 first-boot-set-mac \
10 http-redirect-awk \
11 usb-ctrl \
12 "
13PACKAGECONFIG[first-boot-set-hostname] = "-Dfirst-boot-set-hostname=enabled, -Dfirst-boot-set-hostname=disabled"
14PACKAGECONFIG[first-boot-set-mac] = "-Dfirst-boot-set-mac=enabled, -Dfirst-boot-set-mac=disabled"
15PACKAGECONFIG[http-redirect-awk] = "-Dhttp-redirect=enabled, -Dhttp-redirect=disabled"
16PACKAGECONFIG[usb-ctrl] = "-Dusb-ctrl=enabled, -Dusb-ctrl=disabled"
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050017PV = "1.0+git${SRCPV}"
Ed Tanous9936f862022-09-19 09:13:20 -070018PR = "r1"
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050019
Patrick Williamsbb99d222022-01-24 15:55:09 -060020SRC_URI = "git://github.com/openbmc/phosphor-misc;branch=master;protocol=https"
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050021
22S = "${WORKDIR}/git"
Ed Tanous9936f862022-09-19 09:13:20 -070023SYSTEMD_PACKAGES = "${PHOSPHOR_MISC_PACKAGES}"
24SYSTEMD_SERVICE:${PN}-first-boot-set-hostname = "first-boot-set-hostname.service"
25SYSTEMD_SERVICE:${PN}-first-boot-set-mac = "first-boot-set-mac@.service"
26SYSTEMD_SERVICE:${PN}-http-redirect-awk = " \
27 http-redirect@.service \
28 http-redirect.socket \
29 "
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050030
31inherit meson
32inherit pkgconfig
33inherit systemd
34
Ed Tanous9936f862022-09-19 09:13:20 -070035PACKAGES = "${PHOSPHOR_MISC_PACKAGES}"
36
37RDEPENDS:${PN}-http-redirect-awk = "${VIRTUAL-RUNTIME_base-utils}"
Xie Ningc9883302022-12-14 16:41:12 +080038RDEPENDS:${PN}-first-boot-set-hostname += "bash"
39RDEPENDS:${PN}-first-boot-set-mac += "bash"
40RDEPENDS:${PN}-usb-ctrl += "bash"
Ed Tanous9936f862022-09-19 09:13:20 -070041
42# first-boot-set-hostname
43FILES:${PN}-first-boot-set-hostname = "${bindir}/first-boot-set-hostname.sh"
44# first-boot-set-mac
45FILES:${PN}-first-boot-set-mac = "${bindir}/first-boot-set-mac.sh"
46# http-redirect-awk
47FILES:${PN}-http-redirect-awk = "${bindir}/http-redirect.awk"
48# usb-ctrl
49FILES:${PN}-usb-ctrl = "${bindir}/usb-ctrl"
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050050
51PHOSPHOR_MISC_PACKAGES = " \
52 ${@bb.utils.contains('PACKAGECONFIG', 'first-boot-set-hostname', '${PN}-first-boot-set-hostname', '', d)} \
53 ${@bb.utils.contains('PACKAGECONFIG', 'first-boot-set-mac', '${PN}-first-boot-set-mac', '', d)} \
54 ${@bb.utils.contains('PACKAGECONFIG', 'http-redirect-awk', '${PN}-http-redirect-awk', '', d)} \
55 ${@bb.utils.contains('PACKAGECONFIG', 'usb-ctrl', '${PN}-usb-ctrl', '', d)} \
56 "
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050057PACKAGE_BEFORE_PN += "${PHOSPHOR_MISC_PACKAGES}"