blob: 835405eaf17e760ee41d255e25af2a447c3e1f93 [file] [log] [blame]
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -05001SUMMARY = "Miscellaneous OpenBMC functions"
2HOMEPAGE = "https://github.com/openbmc/phosphor-misc"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
5PR = "r1"
6PV = "1.0+git${SRCPV}"
7
Patrick Williamsbb99d222022-01-24 15:55:09 -06008SRC_URI = "git://github.com/openbmc/phosphor-misc;branch=master;protocol=https"
Andrew Geissler41afbd72021-10-26 19:52:19 +00009SRCREV = "669bb350cd2722f0d2bfd6cb4a22142e7e6c1488"
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050010
11S = "${WORKDIR}/git"
12
13inherit meson
14inherit pkgconfig
15inherit systemd
16
17DEPENDS = "systemd"
18
19PHOSPHOR_MISC_PACKAGES = " \
20 ${@bb.utils.contains('PACKAGECONFIG', 'first-boot-set-hostname', '${PN}-first-boot-set-hostname', '', d)} \
21 ${@bb.utils.contains('PACKAGECONFIG', 'first-boot-set-mac', '${PN}-first-boot-set-mac', '', d)} \
22 ${@bb.utils.contains('PACKAGECONFIG', 'http-redirect-awk', '${PN}-http-redirect-awk', '', d)} \
23 ${@bb.utils.contains('PACKAGECONFIG', 'usb-ctrl', '${PN}-usb-ctrl', '', d)} \
24 "
25
Patrick Williams12fc9392021-08-06 09:16:53 -050026PACKAGES:remove = "${PN}"
27RDEPENDS:${PN}-dev = ""
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050028
29PACKAGE_BEFORE_PN += "${PHOSPHOR_MISC_PACKAGES}"
30SYSTEMD_PACKAGES = "${PHOSPHOR_MISC_PACKAGES}"
31
32PACKAGECONFIG ??= " \
33 first-boot-set-hostname \
34 first-boot-set-mac \
35 http-redirect-awk \
36 usb-ctrl \
37 "
38
39PACKAGECONFIG[first-boot-set-hostname] = "-Dfirst-boot-set-hostname=enabled, -Dfirst-boot-set-hostname=disabled"
40PACKAGECONFIG[first-boot-set-mac] = "-Dfirst-boot-set-mac=enabled, -Dfirst-boot-set-mac=disabled"
41PACKAGECONFIG[http-redirect-awk] = "-Dhttp-redirect=enabled, -Dhttp-redirect=disabled"
42PACKAGECONFIG[usb-ctrl] = "-Dusb-ctrl=enabled, -Dusb-ctrl=disabled"
43
44# first-boot-set-hostname
Patrick Williams12fc9392021-08-06 09:16:53 -050045FILES:${PN}-first-boot-set-hostname = "${bindir}/first-boot-set-hostname.sh"
46SYSTEMD_SERVICE:${PN}-first-boot-set-hostname = "first-boot-set-hostname.service"
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050047
48# first-boot-set-mac
Patrick Williams12fc9392021-08-06 09:16:53 -050049FILES:${PN}-first-boot-set-mac = "${bindir}/first-boot-set-mac.sh"
50SYSTEMD_SERVICE:${PN}-first-boot-set-mac = "first-boot-set-mac@.service"
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050051
52# http-redirect-awk
Patrick Williams12fc9392021-08-06 09:16:53 -050053FILES:${PN}-http-redirect-awk = "${bindir}/http-redirect.awk"
54SYSTEMD_SERVICE:${PN}-http-redirect-awk = " \
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050055 http-redirect@.service \
56 http-redirect.socket \
57 "
Patrick Williams12fc9392021-08-06 09:16:53 -050058RDEPENDS:${PN}-http-redirect-awk = "${VIRTUAL-RUNTIME_base-utils}"
Adriana Kobylak15a8b0e2020-06-02 13:18:36 -050059
60# usb-ctrl
Patrick Williams12fc9392021-08-06 09:16:53 -050061FILES:${PN}-usb-ctrl = "${bindir}/usb-ctrl"