blob: 59596eb070e308116a2645a281e94e791a192d5b [file] [log] [blame]
Cyril Burb73580e2017-01-12 18:13:30 +11001SUMMARY = "Phosphor OpenBMC MBOX Daemon"
2DESCRIPTION = "Phosphor OpenBMC MBOX Daemon"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
6
7inherit autotools pkgconfig
8inherit obmc-phosphor-systemd
9
10DEPENDS += "autoconf-archive-native"
11
12S = "${WORKDIR}/git"
13
14SRC_URI += "git://github.com/openbmc/mboxbridge.git;protocol=https"
15
16SRC_URI += "file://99-aspeed-mbox.rules"
Andrew Jeffery2a0cb542017-01-25 13:17:13 +103017SRC_URI += "file://99-aspeed-lpc-ctrl.rules"
Cyril Burb73580e2017-01-12 18:13:30 +110018SRC_URI += "file://aspeed-lpc-ctrl-h.patch"
19
20SRCREV="8cb799c2d6c2675959e80f2a7b88610aa4f4817a"
21
22MBOXD_FLASH_SIZE ??= "32M"
23SYSTEMD_SUBSTITUTIONS += "FLASH_SIZE:${MBOXD_FLASH_SIZE}:${PN}.service"
24
25# Hacks because ${STAGING_KERNEL_DIR} points to the kernel source tree, not the
26# installed, pre-processed headers. Requires the aspeed-lpc-ctrl-h patch above.
27CFLAGS_append = "-I include"
28
29do_install_append() {
30 install -d ${D}/lib/udev/rules.d
31 install -m 0644 ${WORKDIR}/99-aspeed-mbox.rules ${D}/lib/udev/rules.d
Andrew Jeffery2a0cb542017-01-25 13:17:13 +103032 install -m 0644 ${WORKDIR}/99-aspeed-lpc-ctrl.rules ${D}/lib/udev/rules.d
Cyril Burb73580e2017-01-12 18:13:30 +110033}
Matt Spinler9f77d282017-01-20 15:32:07 -060034
35TMPL = "mboxd-reload@.service"
36TGTFMT = "obmc-chassis-stop@{0}.target"
37INSTFMT = "mboxd-reload@{0}.service"
38FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
39
40SYSTEMD_SERVICE_${PN} += "mboxd.service"
41SYSTEMD_SERVICE_${PN} += "mboxd-reload@.service"
42SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"