blob: bfaff39077c769093204ceaeb736ea8a2c70e690 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "unittest subTest() support and subtests fixture."
2DESCRIPTION = "Adds support for TestCase.subTest.\
3New subtests fixture, providing similar functionality for pure pytest tests."
4HOMEPAGE = "https://github.com/pytest-dev/pytest-subtests"
5BUGTRACKER = "https://github.com/pytest-dev/pytest-subtests/issues"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=242b4e17fa287dcf7aef372f6bc3dcb1"
9
Patrick Williams2390b1b2022-11-03 13:47:49 -050010SRC_URI[sha256sum] = "c0317cd5f6a5eb3e957e89dbe4fc3322a9afddba2db8414355ed2a2cb91a844e"
Andrew Geissler9aee5002022-03-30 16:27:02 +000011
12inherit pypi setuptools3
13
14DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
15
16RDEPENDS:${PN} += " \
17 ${PYTHON_PN}-pytest \
18"
19
20BBCLASSEXTEND = "native nativesdk"