blob: 36fa5efd217846f811dabf3f1b412de4baa0530c [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "The NTFS-3G driver is an open source, freely available NTFS driver for Linux with read and write support."
2HOMEPAGE = "http://www.ntfs-3g.org/"
3DEPENDS = "fuse libgcrypt"
4PROVIDES = "ntfsprogs ntfs-3g"
5LICENSE = "GPLv2 & LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a"
8
9SRC_URI = "http://tuxera.com/opensource/ntfs-3g_ntfsprogs-${PV}.tgz \
10 file://0001-libntfs-3g-Makefile.am-fix-install-failed-while-host.patch \
11"
12S = "${WORKDIR}/ntfs-3g_ntfsprogs-${PV}"
13SRC_URI[md5sum] = "d97474ae1954f772c6d2fa386a6f462c"
14SRC_URI[sha256sum] = "3e5a021d7b761261836dcb305370af299793eedbded731df3d6943802e1262d5"
15
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016UPSTREAM_CHECK_URI = "https://www.tuxera.com/community/open-source-ntfs-3g/"
17UPSTREAM_CHECK_REGEX = "ntfs-3g_ntfsprogs-(?P<pver>\d+(\.\d+)+)\.tgz"
18
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019inherit autotools pkgconfig
20
21PACKAGECONFIG ??= ""
22PACKAGECONFIG[uuid] = "--with-uuid,--without-uuid,util-linux"
23
24# required or it calls ldconfig at install step
25EXTRA_OEMAKE = "LDCONFIG=echo"
26
27PACKAGES =+ "ntfs-3g ntfsprogs libntfs-3g"
28
Patrick Williams213cb262021-08-07 19:21:33 -050029FILES:ntfs-3g = "${base_sbindir}/*.ntfs-3g ${bindir}/ntfs-3g* ${base_sbindir}/mount.ntfs"
30RDEPENDS:ntfs-3g += "fuse"
31RRECOMMENDS:ntfs-3g = "util-linux-mount"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050032
Patrick Williams213cb262021-08-07 19:21:33 -050033FILES:ntfsprogs = "${base_sbindir}/* ${bindir}/* ${sbindir}/*"
34FILES:libntfs-3g = "${libdir}/*${SOLIBS}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035
Patrick Williams213cb262021-08-07 19:21:33 -050036do_install:append() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050037 # Standard mount will execute the program /sbin/mount.TYPE when called.
38 # Add a symbolic link to let mount find ntfs.
39 ln -sf mount.ntfs-3g ${D}${base_sbindir}/mount.ntfs
Brad Bishop6e60e8b2018-02-01 10:27:11 -050040 rmdir ${D}${libdir}/ntfs-3g
Andrew Geissler82c905d2020-04-13 13:39:40 -050041
42 # Handle when usrmerge is in effect. Some files are installed to /sbin
43 # regardless of the value of ${base_sbindir}.
44 if [ "${base_sbindir}" != /sbin ] && [ -d ${D}/sbin ]; then
45 mkdir -p ${D}${base_sbindir}
46 mv ${D}/sbin/* ${D}${base_sbindir}
47 rmdir ${D}/sbin
48 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050049}
50
51# Satisfy the -dev runtime dependency
Patrick Williams213cb262021-08-07 19:21:33 -050052ALLOW_EMPTY:${PN} = "1"