blob: af3054dcbc71f285bc42d6bd2dc04ac1d29205b6 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001DESCRIPTION = "Lua is a powerful light-weight programming language designed \
2for extending applications."
3LICENSE = "MIT"
Andrew Geisslereef63862021-01-29 15:58:13 -06004LIC_FILES_CHKSUM = "file://doc/readme.html;beginline=318;endline=352;md5=f43d8ee6bc4df18ef8b276439cc4a153"
Brad Bishopc342db32019-05-15 21:57:59 -04005HOMEPAGE = "http://www.lua.org/"
6
Brad Bishopc342db32019-05-15 21:57:59 -04007SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz;name=tarballsrc \
8 file://lua.pc.in \
Brad Bishop00ab2372019-10-14 11:06:18 -04009 file://0001-Allow-building-lua-without-readline-on-Linux.patch \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050010 file://CVE-2020-15888.patch \
Andrew Geisslerd688a012020-09-18 13:36:00 -050011 file://0001-Fixed-bug-barriers-cannot-be-active-during-sweep.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040012 "
13
14# if no test suite matches PV release of Lua exactly, download the suite for the closest Lua release.
15PV_testsuites = "5.3.4"
16
17SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', \
18 'http://www.lua.org/tests/lua-${PV_testsuites}-tests.tar.gz;name=tarballtest \
19 file://run-ptest \
20 ', '', d)}"
21
Andrew Geisslereef63862021-01-29 15:58:13 -060022SRC_URI[tarballsrc.md5sum] = "83f23dbd5230140a3770d5f54076948d"
23SRC_URI[tarballsrc.sha256sum] = "fc5fd69bb8736323f026672b1b7235da613d7177e72558893a0bdcd320466d60"
Brad Bishopc342db32019-05-15 21:57:59 -040024SRC_URI[tarballtest.md5sum] = "b14fe3748c1cb2d74e3acd1943629ba3"
25SRC_URI[tarballtest.sha256sum] = "b80771238271c72565e5a1183292ef31bd7166414cd0d43a8eb79845fa7f599f"
26
27inherit pkgconfig binconfig ptest
28
Brad Bishop00ab2372019-10-14 11:06:18 -040029PACKAGECONFIG ??= "readline"
30PACKAGECONFIG[readline] = ",,readline"
31
Brad Bishopc342db32019-05-15 21:57:59 -040032TARGET_CC_ARCH += " -fPIC ${LDFLAGS}"
Brad Bishop00ab2372019-10-14 11:06:18 -040033EXTRA_OEMAKE = "'CC=${CC} -fPIC' 'MYCFLAGS=${CFLAGS} -fPIC' MYLDFLAGS='${LDFLAGS}'"
Brad Bishopc342db32019-05-15 21:57:59 -040034
Patrick Williams213cb262021-08-07 19:21:33 -050035do_configure:prepend() {
Brad Bishopc342db32019-05-15 21:57:59 -040036 sed -i -e s:/usr/local:${prefix}:g src/luaconf.h
Andrew Geissler82c905d2020-04-13 13:39:40 -050037 sed -i -e s:lib/lua/:${baselib}/lua/:g src/luaconf.h
Brad Bishopc342db32019-05-15 21:57:59 -040038}
39
40do_compile () {
Brad Bishop00ab2372019-10-14 11:06:18 -040041 oe_runmake ${@bb.utils.contains('PACKAGECONFIG', 'readline', 'linux', 'linux-no-readline', d)}
Brad Bishopc342db32019-05-15 21:57:59 -040042}
43
44do_install () {
45 oe_runmake \
46 'INSTALL_TOP=${D}${prefix}' \
47 'INSTALL_BIN=${D}${bindir}' \
48 'INSTALL_INC=${D}${includedir}/' \
49 'INSTALL_MAN=${D}${mandir}/man1' \
50 'INSTALL_SHARE=${D}${datadir}/lua' \
51 'INSTALL_LIB=${D}${libdir}' \
52 'INSTALL_CMOD=${D}${libdir}/lua/5.3' \
53 install
54 install -d ${D}${libdir}/pkgconfig
55
56 sed -e s/@VERSION@/${PV}/ ${WORKDIR}/lua.pc.in > ${WORKDIR}/lua.pc
57 install -m 0644 ${WORKDIR}/lua.pc ${D}${libdir}/pkgconfig/
58 rmdir ${D}${datadir}/lua/5.3
59 rmdir ${D}${datadir}/lua
60}
61
62do_install_ptest () {
63 cp -R --no-dereference --preserve=mode,links -v ${WORKDIR}/lua-${PV_testsuites}-tests ${D}${PTEST_PATH}/test
64}
65
66BBCLASSEXTEND = "native nativesdk"