blob: 06f97940cbf2b5333680cbdc3fb325e493c4cf6d [file] [log] [blame]
Brad Bishop868407c2019-11-04 13:24:47 -05001SUMMARY = "Unicode Character Database"
2HOMEPAGE = "https://unicode.org/ucd/"
3LICENSE = "MIT"
Andrew Geissler2ee498a2020-05-29 15:52:06 -05004LIC_FILES_CHKSUM = "file://../license.html;beginline=42;endline=85;md5=ddcaebcc17ab633995f12c383599f377"
Brad Bishop868407c2019-11-04 13:24:47 -05005
6SRC_URI = " \
7 https://www.unicode.org/Public/zipped/${PV}/UCD.zip;name=ucd;subdir=ucd \
Andrew Geissler2ee498a2020-05-29 15:52:06 -05008 file://license.html \
Brad Bishop868407c2019-11-04 13:24:47 -05009"
10SRC_URI[ucd.md5sum] = "430cbdac2615451571dd69a976dd08f6"
11SRC_URI[ucd.sha256sum] = "25ba51a0d4c6fa41047b7a5e5733068d4a734588f055f61e85f450097834a0a6"
12
Brad Bishop868407c2019-11-04 13:24:47 -050013inherit allarch
14
15do_configure[noexec] = "1"
16
17do_install() {
18 install -d ${D}${datadir}/unicode
19 cp -rf ${WORKDIR}/ucd ${D}${datadir}/unicode
20}
21
Patrick Williams213cb262021-08-07 19:21:33 -050022FILES:${PN} = "${datadir}/unicode/ucd"