blob: c8b9a429ed7e0069344b8fa1a9628dc5e0510046 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A simple wrapper around optparse for powerful command line utilities."
2DESCRIPTION = "\
3Click is a Python package for creating beautiful command line interfaces \
4in a composable way with as little code as necessary. It's the "Command \
5Line Interface Creation Kit". It's highly configurable but comes with \
6sensible defaults out of the box."
7HOMEPAGE = "http://click.pocoo.org/"
8LICENSE = "BSD-3-Clause"
Andrew Geisslereafcbb82020-06-05 17:59:17 -05009LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=1fa98232fd645608937a0fdc82e999b8"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070011SRC_URI[sha256sum] = "8c04c11192119b1ef78ea049e0a6f0463e4c48ef00a30160c704337586f3ad7a"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
Andrew Geisslerd221e032020-07-10 16:13:21 -050013inherit pypi setuptools3 ptest
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
Patrick Williams213cb262021-08-07 19:21:33 -050019RDEPENDS:${PN}-ptest += " \
Andrew Geisslerd221e032020-07-10 16:13:21 -050020 ${PYTHON_PN}-pytest \
21 ${PYTHON_PN}-terminal \
22 ${PYTHON_PN}-unixadmin \
23"
24
25do_install_ptest() {
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050026 install -d ${D}${PTEST_PATH}/tests
27 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
28 cp -rf ${S}/setup.cfg ${D}${PTEST_PATH}/
29 cp -rf ${S}/docs ${D}${PTEST_PATH}/
Andrew Geisslerd221e032020-07-10 16:13:21 -050030}
Andrew Geissler82c905d2020-04-13 13:39:40 -050031
32UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/"
33
34CLEANBROKEN = "1"
35
Patrick Williams213cb262021-08-07 19:21:33 -050036RDEPENDS:${PN} += "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050037 ${PYTHON_PN}-io \
38 ${PYTHON_PN}-threading \
39 "
40
41BBCLASSEXTEND = "native nativesdk"