blob: 57db204649bfb2bbcb951049d92cb876b26f6ef9 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "The Swiss Army knife of Python web development"
2DESCRIPTION = "\
3Werkzeug started as simple collection of various utilities for WSGI \
4applications and has become one of the most advanced WSGI utility modules. \
5It includes a powerful debugger, full featured request and response objects, \
6HTTP utilities to handle entity tags, cache control headers, HTTP dates, \
7cookie handling, file uploads, a powerful URL routing system and a bunch \
8of community contributed addon modules."
9HOMEPAGE = "http://werkzeug.pocoo.org/"
Andrew Geissler32b11992021-03-31 13:37:05 -050010LICENSE = "BSD-3-Clause"
Andrew Geissler82c905d2020-04-13 13:39:40 -050011LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
12
13PYPI_PACKAGE = "Werkzeug"
14
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070015SRC_URI[sha256sum] = "1de1db30d010ff1af14a009224ec49ab2329ad2cde454c8a708130642d579c42"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
17inherit pypi setuptools3
18
19CLEANBROKEN = "1"
20
Patrick Williams213cb262021-08-07 19:21:33 -050021RDEPENDS:${PN} += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050022 ${PYTHON_PN}-datetime \
23 ${PYTHON_PN}-difflib \
24 ${PYTHON_PN}-email \
25 ${PYTHON_PN}-html \
26 ${PYTHON_PN}-io \
27 ${PYTHON_PN}-json \
Andrew Geissler7f40b712020-05-15 14:09:53 -050028 ${PYTHON_PN}-logging \
Andrew Geissler82c905d2020-04-13 13:39:40 -050029 ${PYTHON_PN}-netclient \
30 ${PYTHON_PN}-netserver \
31 ${PYTHON_PN}-numbers \
32 ${PYTHON_PN}-pkgutil \
33 ${PYTHON_PN}-pprint \
34 ${PYTHON_PN}-simplejson \
35 ${PYTHON_PN}-threading \
36 ${PYTHON_PN}-unixadmin \
37 ${PYTHON_PN}-misc \
38"