blob: 74bface4a18ba43d1ea16c96da95b625bafc0f70 [file] [log] [blame]
Andrew Geisslerc926e172021-05-07 16:11:35 -05001SUMMARY = "interface to seccomp filtering mechanism"
2DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp."
3HOMEPAGE = "https://github.com/seccomp/libseccomp"
4SECTION = "security"
5LICENSE = "LGPL-2.1"
6LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f"
7
8DEPENDS += "gperf-native"
9
Andrew Geissler5f350902021-07-23 13:09:54 -040010PV .= "+git${SRCPV}"
11SRCREV = "5822e50c2920ce597d038077dea4a0eedf193f86"
Andrew Geisslerc926e172021-05-07 16:11:35 -050012
Andrew Geissler5f350902021-07-23 13:09:54 -040013SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=main \
14 file://0001-configure.ac-Bump-version-to-2.5.99.patch \
15 file://0001-arch-Add-riscv32-architecture-support.patch \
16 file://0002-Regenerate-syscall-cvs-file-from-5.13-rc5-kernel.patch \
Andrew Geisslerc926e172021-05-07 16:11:35 -050017 file://run-ptest \
18 "
19
Andrew Geisslerc926e172021-05-07 16:11:35 -050020S = "${WORKDIR}/git"
21
22inherit autotools-brokensep pkgconfig ptest features_check
23
24REQUIRED_DISTRO_FEATURES = "seccomp"
25
26PACKAGECONFIG ??= ""
27PACKAGECONFIG[python] = "--enable-python, --disable-python, python3"
28
29DISABLE_STATIC = ""
30
31do_compile_ptest() {
32 oe_runmake -C tests check-build
33}
34
35do_install_ptest() {
36 install -d ${D}${PTEST_PATH}/tests
37 install -d ${D}${PTEST_PATH}/tools
38 for file in $(find tests/* -executable -type f); do
39 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
40 done
41 for file in $(find tests/*.tests -type f); do
42 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
43 done
44 for file in $(find tools/* -executable -type f); do
45 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
46 done
47 # Overwrite libtool wrappers with real executables
48 for file in $(find tools/.libs/* -executable -type f); do
49 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
50 done
51}
52
Patrick Williams213cb262021-08-07 19:21:33 -050053FILES:${PN} = "${bindir} ${libdir}/${BPN}.so*"
54FILES:${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
Andrew Geisslerc926e172021-05-07 16:11:35 -050055
Patrick Williams213cb262021-08-07 19:21:33 -050056RDEPENDS:${PN}-ptest = "coreutils bash"