blob: e888202b77575b508f06a78e2e8f658df2fe756a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "An HTTP library implementation in C"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "libsoup is an HTTP client/server library for GNOME. It uses GObjects \
3and the glib main loop, to integrate well with GNOME applications."
Andrew Geissler82c905d2020-04-13 13:39:40 -05004HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
5BUGTRACKER = "https://bugzilla.gnome.org/"
6SECTION = "x11/gnome/libs"
7LICENSE = "LGPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
9
Andrew Geissler5199d832021-09-24 16:47:35 -050010DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 libpsl"
Andrew Geissler82c905d2020-04-13 13:39:40 -050011
12SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
13
14SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060015SRC_URI[sha256sum] = "170c3f8446b0f65f8e4b93603349172b1085fb8917c181d10962f02bb85f5387"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
17CVE_PRODUCT = "libsoup"
18
19S = "${WORKDIR}/libsoup-${PV}"
20
21inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc
22
23GIR_MESON_ENABLE_FLAG = 'enabled'
24GIR_MESON_DISABLE_FLAG = 'disabled'
25
26# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
27PACKAGECONFIG ??= ""
28PACKAGECONFIG[gnome] = "-Dgnome=true,-Dgnome=false"
29PACKAGECONFIG[gssapi] = "-Dgssapi=enabled,-Dgssapi=disabled,krb5"
30
Patrick Williams213cb262021-08-07 19:21:33 -050031EXTRA_OEMESON:append = " -Dvapi=disabled -Dtls_check=false"
Andrew Geissler82c905d2020-04-13 13:39:40 -050032
33GTKDOC_MESON_OPTION = "gtk_doc"
34
35# When built without gnome support, libsoup-2.4 will contain only one shared lib
36# and will therefore become subject to renaming by debian.bbclass. Prevent
37# renaming in order to keep the package name consistent regardless of whether
38# gnome support is enabled or disabled.
Patrick Williams213cb262021-08-07 19:21:33 -050039DEBIAN_NOAUTONAME:${PN} = "1"
Andrew Geissler82c905d2020-04-13 13:39:40 -050040
41# glib-networking is needed for SSL, proxies, etc.
Patrick Williams213cb262021-08-07 19:21:33 -050042RRECOMMENDS:${PN} = "glib-networking"
Andrew Geissler82c905d2020-04-13 13:39:40 -050043
Andrew Geissler5a43b432020-06-13 10:46:56 -050044BBCLASSEXTEND = "native nativesdk"