blob: 98577fe3ef9562776258f7251abe4c02c26ae43f [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Collection of simple PIN or passphrase entry dialogs"
2DESCRIPTION = "\
3 Pinentry is a collection of simple PIN or passphrase entry dialogs which \
4 utilize the Assuan protocol as described by the aegypten project; see \
5 http://www.gnupg.org/aegypten/ for details."
6
7HOMEPAGE = "http://www.gnupg.org/related_software/pinentry/index.en.html"
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e"
10
Brad Bishop316dfdd2018-06-25 12:45:53 -040011DEPENDS = "gettext-native libassuan libgpg-error"
12
13UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
14SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
15 file://libassuan_pkgconf.patch \
16 file://gpg-error_pkconf.patch \
17"
18
Andrew Geissler90fd73c2021-03-05 15:25:55 -060019SRC_URI[sha256sum] = "cd12a064013ed18e2ee8475e669b9f58db1b225a0144debdb85a68cecddba57f"
Brad Bishop316dfdd2018-06-25 12:45:53 -040020
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021inherit autotools pkgconfig
Brad Bishop316dfdd2018-06-25 12:45:53 -040022
23PACKAGECONFIG ??= "ncurses libcap"
24
25PACKAGECONFIG[ncurses] = "--enable-ncurses --with-ncurses-include-dir=${STAGING_INCDIR}, --disable-ncurses, ncurses"
26PACKAGECONFIG[libcap] = "--with-libcap, --without-libcap, libcap"
Brad Bishop15ae2502019-06-18 21:44:24 -040027PACKAGECONFIG[qt] = "--enable-pinentry-qt, --disable-pinentry-qt, qtbase-native qtbase"
Brad Bishop316dfdd2018-06-25 12:45:53 -040028PACKAGECONFIG[gtk2] = "--enable-pinentry-gtk2, --disable-pinentry-gtk2, gtk+ glib-2.0"
29
Brad Bishop316dfdd2018-06-25 12:45:53 -040030PACKAGECONFIG[secret] = "--enable-libsecret, --disable-libsecret, libsecret"
31
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080032EXTRA_OECONF = " \
33 --disable-rpath \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080034"
35
Brad Bishop1d80a2e2019-11-15 16:35:03 -050036BBCLASSEXTEND = "native nativesdk"