blob: 1c743ef7ab07bc1d41594216bf14a82a16938fd8 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "xorriso copies file objects from POSIX compliant filesystems \
2into Rock Ridge enhanced ISO 9660 filesystems and allows session-wise \
3manipulation of such filesystems"
4
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8SRC_URI = "http://www.gnu.org/software/${BPN}/${BPN}-${PV}.tar.gz"
9
Brad Bishop2d39a062019-10-28 08:33:36 -040010SRC_URI[md5sum] = "e5fbae9ada52730fbe248ab9a88e7127"
11SRC_URI[sha256sum] = "a93fa7ae5bb1902198cddfec25201388156932f36f2f5da829bf4fcae9a6062b"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050012
13PACKAGECONFIG ??= "acl attr zlib bzip2 readline"
14PACKAGECONFIG[acl] = "--enable-libacl,--disable-libacl,acl,"
15PACKAGECONFIG[attr] = "--enable-xattr,--disable-xattr,attr,"
16PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
17PACKAGECONFIG[bzip2] = "--enable-libbz2,--disable-libbz2,bzip2,"
18PACKAGECONFIG[readline] = "--enable-libreadline,--disable-libreadline,readline,"
19
20inherit autotools-brokensep pkgconfig distro_features_check
21
22do_configure_prepend () {
23 touch NEWS
24}
25
26RDEPENDS_${PN} = "tk"
27REQUIRED_DISTRO_FEATURES = "x11"
28
29BBCLASSEXTEND = "native"