blob: 05fc99bdc77134d9c7d41d36c333a742e83cc0e5 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A sophisticated network protocol analyzer"
2HOMEPAGE = "http://www.tcpdump.org/"
Brad Bishop19323692019-04-05 15:28:33 -04003SECTION = "net"
Brad Bishop2d39a062019-10-28 08:33:36 -04004LICENSE = "BSD-3-Clause"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005LIC_FILES_CHKSUM = "file://LICENSE;md5=1d4b0366557951c84a94fabe3529f867"
Brad Bishop19323692019-04-05 15:28:33 -04006
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007DEPENDS = "libpcap"
8
Brad Bishop63ae8782019-10-09 09:56:13 -04009RDEPENDS_${PN}-ptest += " make perl \
10 perl-module-file-basename \
11 perl-module-posix \
12 perl-module-carp"
13
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014SRC_URI = " \
15 http://www.tcpdump.org/release/${BP}.tar.gz \
16 file://unnecessary-to-check-libpcap.patch \
Brad Bishop19323692019-04-05 15:28:33 -040017 file://avoid-absolute-path-when-searching-for-libdlpi.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018 file://add-ptest.patch \
19 file://run-ptest \
20"
21
Brad Bishop63ae8782019-10-09 09:56:13 -040022SRC_URI[md5sum] = "a4ead41d371f91aa0a2287f589958bae"
23SRC_URI[sha256sum] = "2cd47cb3d460b6ff75f4a9940f594317ad456cfbf2bd2c8e5151e16559db6410"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025inherit autotools-brokensep ptest
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026
Brad Bishop19323692019-04-05 15:28:33 -040027PACKAGECONFIG ?= "openssl"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028
Brad Bishop19323692019-04-05 15:28:33 -040029PACKAGECONFIG[libcap-ng] = "--with-cap-ng,--without-cap-ng,libcap-ng"
30PACKAGECONFIG[openssl] = "--with-crypto,--without-openssl --without-crypto,openssl"
31PACKAGECONFIG[smi] = "--with-smi,--without-smi,libsmi"
Brad Bishop63ae8782019-10-09 09:56:13 -040032# Note: CVE-2018-10103 (SMB - partially fixed, but SMB printing disabled)
33PACKAGECONFIG[smb] = "--enable-smb,--disable-smb"
Brad Bishop19323692019-04-05 15:28:33 -040034
35EXTRA_AUTORECONF += "-I m4"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036
37do_configure_prepend() {
38 mkdir -p ${S}/m4
39 if [ -f aclocal.m4 ]; then
40 mv aclocal.m4 ${S}/m4
41 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050042}
43
44do_install_append() {
Brad Bishop19323692019-04-05 15:28:33 -040045 # make install installs an unneeded extra copy of the tcpdump binary
Brad Bishop6e60e8b2018-02-01 10:27:11 -050046 rm -f ${D}${sbindir}/tcpdump.${PV}
47}
48
49do_compile_ptest() {
50 oe_runmake buildtest-TESTS
51}