blob: e43a39b613ddb6e0c13d887090c0737ce7ceb2aa [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001# This recipe is modified from the recipe originally found in the Open-Switch
2# repository:
3#
4# https://github.com/open-switch/ops-build
5# yocto/openswitch/meta-foss-openswitch/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.0.5.bb
6# Commit 9008de2d8e100f3f868c66765742bca9fa98f3f9
7#
8# The recipe packaging has been relicensed under the MIT license for inclusion
9# in meta-openembedded by agreement of the author (Diego Dompe).
10#
11
12SUMMARY = "Tools to enhance VMWare guest integration and performance"
13HOMEPAGE = "https://github.com/vmware/open-vm-tools"
14SECTION = "vmware-tools"
15
16LICENSE = "LGPL-2.0 & GPL-2.0 & BSD & CDDL-1.0"
17LIC_FILES_CHKSUM = "file://LICENSE;md5=559317809c5444fb39ceaf6ac45c43ac"
18LICENSE_modules/freebsd/vmblock = "BSD"
19LICENSE_modules/freebsd/vmmemctl = "GPL-2.0"
20LICENSE_modules/freebsd/vmxnet = "GPL-2.0"
21LICENSE_modules/linux = "GPL-2.0"
22LICENSE_modules/solaris = "CDDL-1.0"
23
24SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https \
Brad Bishop15ae2502019-06-18 21:44:24 -040025 file://tools.conf \
26 file://vmtoolsd.service \
27 file://vmtoolsd.init \
28 file://0001-configure.ac-don-t-use-dnet-config.patch;patchdir=.. \
29 file://0002-add-include-sys-sysmacros.h.patch;patchdir=.. \
30 file://0003-Use-configure-test-for-struct-timespec.patch;patchdir=.. \
31 file://0004-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch;patchdir=.. \
32 file://0005-Use-configure-to-test-for-feature-instead-of-platfor.patch;patchdir=.. \
33 file://0006-Use-configure-test-for-sys-stat.h-include.patch;patchdir=.. \
34 file://0007-Fix-subdir-objects-configure-error.patch;patchdir=.. \
35 file://0008-include-poll.h-instead-of-sys-poll.h.patch;patchdir=.. \
36 file://0009-Rename-poll.h-to-vm_poll.h.patch;patchdir=.. \
37 file://0010-use-posix-strerror_r-unless-on-gnu-libc-system.patch;patchdir=.. \
38 file://0011-Use-uintmax_t-for-handling-rlim_t.patch;patchdir=.. \
39 file://0012-Use-off64_t-instead-of-__off64_t.patch;patchdir=.. \
40 file://0013-misc-Do-not-print-NULL-string-into-logs.patch;patchdir=.. \
Brad Bishop2d39a062019-10-28 08:33:36 -040041 file://0001-GitHub-Issue-367.-Remove-references-to-deprecated-G_.patch;patchdir=.. \
Brad Bishop15ae2502019-06-18 21:44:24 -040042"
Brad Bishop2d39a062019-10-28 08:33:36 -040043SRCREV = "d3edfd142a81096f9f58aff17d84219b457f4987"
Brad Bishop19323692019-04-05 15:28:33 -040044
45S = "${WORKDIR}/git/open-vm-tools"
46
47DEPENDS = "glib-2.0 glib-2.0-native util-linux libdnet procps libtirpc"
48
49# open-vm-tools is supported only on x86.
50COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
51
52inherit autotools pkgconfig systemd update-rc.d
53
54SYSTEMD_SERVICE_${PN} = "vmtoolsd.service"
55
56EXTRA_OECONF = "--without-icu --disable-multimon --disable-docs \
57 --disable-tests --without-gtkmm --without-xerces --without-pam \
Brad Bishop2d39a062019-10-28 08:33:36 -040058 --disable-vgauth --disable-deploypkg \
Brad Bishop19323692019-04-05 15:28:33 -040059 --without-root-privileges --without-kernel-modules"
60
61NO_X11_FLAGS = "--without-x --without-gtk2 --without-gtk3"
62X11_DEPENDS = "libxext libxi libxrender libxrandr libxtst gtk+ gdk-pixbuf"
63PACKAGECONFIG[x11] = ",${NO_X11_FLAGS},${X11_DEPENDS}"
64
65# fuse gets implicitly detected; there is no --without-fuse option.
66PACKAGECONFIG[fuse] = ",,fuse"
67
68CFLAGS_append_toolchain-clang = " -Wno-address-of-packed-member"
69FILES_${PN} += "\
70 ${libdir}/open-vm-tools/plugins/vmsvc/lib*.so \
71 ${libdir}/open-vm-tools/plugins/common/lib*.so \
72 ${sysconfdir}/vmware-tools/tools.conf \
73"
74FILES_${PN}-locale += "${datadir}/open-vm-tools/messages"
75FILES_${PN}-dev += "${libdir}/open-vm-tools/plugins/common/lib*.la"
76
77CONFFILES_${PN} += "${sysconfdir}/vmware-tools/tools.conf"
78
79RDEPENDS_${PN} = "util-linux libdnet fuse"
80
81do_install_append() {
82 ln -sf ${sbindir}/mount.vmhgfs ${D}/sbin/mount.vmhgfs
83 install -d ${D}${sysconfdir}/vmware-tools
84 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
85 install -d ${D}${systemd_unitdir}/system
86 install -m 644 ${WORKDIR}/*.service ${D}${systemd_unitdir}/system
87 else
88 install -d ${D}${sysconfdir}/init.d
89 install -m 0755 ${WORKDIR}/vmtoolsd.init ${D}${sysconfdir}/init.d/vmtoolsd
90 fi
91 install -m 0644 ${WORKDIR}/tools.conf ${D}${sysconfdir}/vmware-tools/tools.conf
92}
93
94do_configure_prepend() {
95 export CUSTOM_DNET_NAME=dnet
96 export CUSTOM_DNET_LIBS=-L${STAGING_LIBDIR}/libdnet.so
97}
98
99INITSCRIPT_PACKAGES = "${PN}"
100INITSCRIPT_NAME_${PN} = "vmtoolsd"
101INITSCRIPT_PARAMS_${PN} = "start 90 2 3 4 5 . stop 60 0 1 6 ."
102
103python() {
104 if 'networking-layer' not in d.getVar('BBFILE_COLLECTIONS').split() or \
105 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
106 raise bb.parse.SkipRecipe('Requires meta-networking and meta-filesystems to be present.')
107}