blob: e2866c8307f6a75dd03b0993782327a3cf82b7ef [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces."
2
3require suricata.inc
4
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=2;md5=596ab7963a1a0e5198e5a1c4aa621843"
6
7SRC_URI = "git://github.com/OISF/libhtp.git;protocol=https;branch=0.5.x"
Andrew Geissler2daf84b2023-03-31 09:57:23 -05008SRCREV = "b14f81bfddbc7206ea713177fcf1e1090257dcd2"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00009
10DEPENDS = "zlib"
11
12inherit autotools-brokensep pkgconfig
13
14CFLAGS += "-D_DEFAULT_SOURCE"
15
16#S = "${WORKDIR}/suricata-${VER}/${BPN}"
17
18S = "${WORKDIR}/git"
19
20do_configure () {
21 cd ${S}
22 ./autogen.sh
23 oe_runconf
24}
25
26RDEPENDS:${PN} += "zlib"
27