blob: 6bbe517df1b02da625c1d2fa3ebc5c6549c823b9 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Inittab configuration for SysVinit"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00002LICENSE = "GPL-2.0-only"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004
Patrick Williamsc124f4f2015-09-15 14:41:29 -05005
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05006SRC_URI = "file://inittab \
7 file://start_getty"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
9S = "${WORKDIR}"
10
11INHIBIT_DEFAULT_DEPS = "1"
12
13do_compile() {
14 :
15}
16
17do_install() {
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050018 install -d ${D}${sysconfdir}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050019 install -m 0644 ${WORKDIR}/inittab ${D}${sysconfdir}/inittab
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050020 install -d ${D}${base_bindir}
21 install -m 0755 ${WORKDIR}/start_getty ${D}${base_bindir}/start_getty
Brad Bishop19323692019-04-05 15:28:33 -040022 sed -e 's,/usr/bin,${bindir},g' -i ${D}${base_bindir}/start_getty
Patrick Williamsc124f4f2015-09-15 14:41:29 -050023
Andrew Geissler20137392023-10-12 04:59:14 -060024 CONSOLES="${SERIAL_CONSOLES}"
25 for s in $CONSOLES
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026 do
Andrew Geissler20137392023-10-12 04:59:14 -060027 speed=$(echo $s | cut -d\; -f 1)
28 device=$(echo $s | cut -d\; -f 2)
29 label=$(echo $device | sed -e 's/tty//' | tail --bytes=5)
30
31 echo "$label:12345:respawn:${sbindir}/ttyrun $device ${base_bindir}/start_getty $speed $device vt102" >> ${D}${sysconfdir}/inittab
Patrick Williamsc124f4f2015-09-15 14:41:29 -050032 done
33
34 if [ "${USE_VT}" = "1" ]; then
35 cat <<EOF >>${D}${sysconfdir}/inittab
36# ${base_sbindir}/getty invocations for the runlevels.
37#
38# The "id" field MUST be the same as the last
39# characters of the device (after "tty").
40#
41# Format:
42# <id>:<runlevels>:<action>:<process>
43#
44
45EOF
46
47 for n in ${SYSVINIT_ENABLED_GETTYS}
48 do
49 echo "$n:12345:respawn:${base_sbindir}/getty 38400 tty$n" >> ${D}${sysconfdir}/inittab
50 done
51 echo "" >> ${D}${sysconfdir}/inittab
52 fi
53}
54
Patrick Williamsc124f4f2015-09-15 14:41:29 -050055# USE_VT and SERIAL_CONSOLES are generally defined by the MACHINE .conf.
56# Set PACKAGE_ARCH appropriately.
57PACKAGE_ARCH = "${MACHINE_ARCH}"
58
Patrick Williams213cb262021-08-07 19:21:33 -050059FILES:${PN} = "${sysconfdir}/inittab ${base_bindir}/start_getty"
60CONFFILES:${PN} = "${sysconfdir}/inittab"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050061
62USE_VT ?= "1"
63SYSVINIT_ENABLED_GETTYS ?= "1"
64
Andrew Geissler20137392023-10-12 04:59:14 -060065RDEPENDS:${PN} = "ttyrun"
Patrick Williams213cb262021-08-07 19:21:33 -050066RCONFLICTS:${PN} = "busybox-inittab"