blob: d1dcd74557a1f66658ce1c3fe71fa03538cf248b [file] [log] [blame]
Brad Bishopbec4ebc2022-08-03 09:55:16 -04001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2
3#
Brad Bishopbec4ebc2022-08-03 09:55:16 -04004# Corstone1000 64-bit machines
5#
6DEPENDS:append:corstone1000 = " gnutls-native"
7CORSTONE1000_DEVICE_TREE:corstone1000-mps3 = "corstone1000-mps3"
8CORSTONE1000_DEVICE_TREE:corstone1000-fvp = "corstone1000-fvp"
9EXTRA_OEMAKE:append:corstone1000 = ' DEVICE_TREE=${CORSTONE1000_DEVICE_TREE}'
10
11SYSROOT_DIRS:append:corstone1000 = " /boot"
12
13SRC_URI:append:corstone1000 = " \
Patrick Williams2a254922023-08-11 09:48:11 -050014 file://0001-FF-A-v15-arm64-smccc-add-support-for-SMCCCv1.2-x0-x1.patch \
15 file://0002-FF-A-v15-lib-uuid-introduce-uuid_str_to_le_bin-funct.patch \
16 file://0003-FF-A-v15-lib-uuid-introduce-testcase-for-uuid_str_to.patch \
17 file://0004-FF-A-v15-arm_ffa-introduce-Arm-FF-A-support.patch \
18 file://0005-FF-A-v15-arm_ffa-introduce-armffa-command.patch \
19 file://0006-FF-A-v15-arm_ffa-introduce-sandbox-FF-A-support.patch \
20 file://0007-FF-A-v15-arm_ffa-introduce-sandbox-test-cases-for-UC.patch \
21 file://0008-FF-A-v15-arm_ffa-introduce-armffa-command-Sandbox-te.patch \
22 file://0009-FF-A-v15-arm_ffa-efi-introduce-FF-A-MM-communication.patch \
23 file://0010-FF-A-v15-arm_ffa-efi-corstone1000-enable-MM-communic.patch \
24 file://0011-efi-corstone1000-fwu-introduce-EFI-capsule-update.patch \
25 file://0012-arm-corstone1000-fix-unrecognized-filesystem-type.patch \
26 file://0013-efi_loader-corstone1000-remove-guid-check-from-corst.patch \
27 file://0014-efi_loader-populate-ESRT-table-if-EFI_ESRT-config-op.patch \
28 file://0015-efi_firmware-add-get_image_info-for-corstone1000.patch \
29 file://0016-efi_loader-fix-null-pointer-exception-with-get_image.patch \
30 file://0017-arm-corstone1000-add-mmc-for-fvp.patch \
31 file://0018-corstone1000-add-compressed-kernel-support.patch \
32 file://0019-Introduce-external-sys-driver-to-device-tree.patch \
33 file://0020-Add-mhu-and-rpmsg-client-to-u-boot-device-tree.patch \
34 file://0021-arm-corstone1000-esrt-support.patch \
35 file://0022-corstone1000-enable-distro-booting-command.patch \
36 file://0023-corstone1000-add-fwu-metadata-store-info.patch \
37 file://0024-fwu_metadata-make-sure-structures-are-packed.patch \
38 file://0025-corstone1000-add-boot-index.patch \
39 file://0026-corstone1000-adjust-boot-bank-and-kernel-location.patch \
40 file://0027-corstone1000-add-nvmxip-fwu-mdata-and-gpt-options.patch \
41 file://0028-nvmxip-move-header-to-include.patch \
42 file://0029-corstone1000-set-kernel_addr-based-on-boot_idx.patch \
43 file://0030-corstone1000-boot-index-from-active.patch \
44 file://0031-corstone1000-enable-PSCI-reset.patch \
45 file://0032-Enable-EFI-set-get-time-services.patch \
Andrew Geissler2edf0642023-09-11 08:24:07 -040046 file://0033-corstone1000-detect-inflated-kernel-size.patch \
47 file://0034-corstone1000-ESRT-add-unique-firmware-GUID.patch \
Patrick Williams975a06f2022-10-21 14:42:47 -050048 "
Brad Bishopbec4ebc2022-08-03 09:55:16 -040049
50#
51# FVP BASE
52#
Andrew Geissler2daf84b2023-03-31 09:57:23 -050053SRC_URI:append:fvp-base = " file://bootargs.cfg \
54 file://0001-Revert-vexpress64-pick-DRAM-size-from-DT.patch \
55 "
Brad Bishopbec4ebc2022-08-03 09:55:16 -040056
57#
58# FVP BASER
59#
60SRC_URI:append:fvp-baser-aemv8r64 = " \
61 file://0001-armv8-Add-ARMv8-MPU-configuration-logic.patch \
62 file://0002-vexpress64-add-MPU-memory-map-for-the-BASER_FVP.patch \
63 file://0003-armv8-Allow-disabling-exception-vectors-on-non-SPL-b.patch \
64 file://0004-armv8-ARMV8_SWITCH_TO_EL1-improvements.patch \
65 file://0005-armv8-Make-disabling-HVC-configurable-when-switching.patch \
66 file://0006-vexpress64-Do-not-set-COUNTER_FREQUENCY.patch \
67 file://0007-vexpress64-Enable-LIBFDT_OVERLAY-in-the-vexpress_aem.patch \
68 file://0008-armv8-Allow-PRBAR-MPU-attributes-to-be-configured.patch \
69 file://0009-armv8-Enable-icache-when-switching-exception-levels-.patch \
70 "
71
72
73#
74# Juno Machines
75#
Patrick Williamsb9af8752023-01-30 13:28:01 -060076SRC_URI:append:juno = " file://0001-configs-vexpress-modify-to-boot-compressed-initramfs.patch"
Brad Bishopbec4ebc2022-08-03 09:55:16 -040077
78
79#
80# TC0 and TC1 MACHINES
81#
82SRC_URI:append:tc = " \
83 file://bootargs.cfg \
Brad Bishopbec4ebc2022-08-03 09:55:16 -040084 "