blob: b6c64685181f445dad469367d51f3d8cce9b6376 [file] [log] [blame]
Andrew Geissler2edf0642023-09-11 08:24:07 -04001require recipes-bsp/uefi/edk2-firmware_202305.bb
Brad Bishopbec4ebc2022-08-03 09:55:16 -04002PROVIDES:remove = "virtual/bootloader"
3
4LICENSE += "& Apache-2.0"
5LIC_FILES_CHKSUM += "file://ShellPkg/Application/sbsa-acs/LICENSE.md;md5=2a944942e1496af1886903d274dedb13"
6
7SRC_URI += "git://github.com/ARM-software/sbsa-acs;destsuffix=edk2/ShellPkg/Application/sbsa-acs;protocol=https;branch=master;name=acs \
8 git://github.com/tianocore/edk2-libc;destsuffix=edk2/edk2-libc;protocol=https;branch=master;name=libc \
Andrew Geissler2edf0642023-09-11 08:24:07 -04009 file://0001-Patch-in-the-paths-to-the-SBSA-test-suite.patch \
10 file://0002-Enforce-using-good-old-BFD-linker.patch \
11 file://0001-Fix-for-mismatch-in-function-prototype.patch;patchdir=ShellPkg/Application/sbsa-acs \
Brad Bishopbec4ebc2022-08-03 09:55:16 -040012 "
13
Andrew Geissler9347dd42023-03-03 12:38:41 -060014
Andrew Geissler2edf0642023-09-11 08:24:07 -040015SRCREV_acs = "23253befbed2aee7304470fd83b78672488a7fc2"
16SRCREV_libc = "d3dea661da9ae4a3421a80905e75a8dc77aa980e"
Brad Bishopbec4ebc2022-08-03 09:55:16 -040017
18# GCC12 trips on it
19#see https://src.fedoraproject.org/rpms/edk2/blob/rawhide/f/0032-Basetools-turn-off-gcc12-warning.patch
20BUILD_CFLAGS += "-Wno-error=stringop-overflow"
21
22COMPATIBLE_HOST = "aarch64.*-linux"
23COMPATIBLE_MACHINE = ""
24PACKAGE_ARCH = "${TUNE_PKGARCH}"
25
26EDK2_PLATFORM = "Shell"
27EDK2_PLATFORM_DSC = "ShellPkg/ShellPkg.dsc"
28EDK2_EXTRA_BUILD = "--module ShellPkg/Application/sbsa-acs/uefi_app/SbsaAvs.inf"
29
30PACKAGES_PATH .= ":${S}/edk2-libc"
31
32do_install() {
33 install -d ${D}/firmware
34 install ${B}/Build/${EDK2_PLATFORM}/${EDK2_BUILD_MODE}_${EDK_COMPILER}/*/Sbsa.efi ${D}/firmware/
35}