blob: a2f0d07f24c79b82431dd8b0dc3a3ebf68054f85 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "haveged - A simple entropy daemon"
2DESCRIPTION = "The haveged project is an attempt to provide an easy-to-use, unpredictable random number generator based upon an adaptation of the HAVEGE algorithm. Haveged was created to remedy low-entropy conditions in the Linux random device that can occur under some workloads, especially on headless servers."
3AUTHOR = "Gary Wuertz"
4HOMEPAGE = "http://www.issihosts.com/haveged/index.html"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM="file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
Brad Bishop779d0ac2019-09-27 08:23:48 -04008# v1.9.6
9SRCREV = "1470a82a7f79110c79beea1ca5f2d3b0fd1a4668"
Brad Bishop19323692019-04-05 15:28:33 -040010SRC_URI = "git://github.com/jirka-h/haveged.git \
Brad Bishop19323692019-04-05 15:28:33 -040011"
12S = "${WORKDIR}/git"
13
14UPSTREAM_CHECK_URI = "https://github.com/jirka-h/haveged/releases"
15
16inherit autotools update-rc.d systemd
17
18EXTRA_OECONF = "\
19 --enable-nistest=yes \
20 --enable-olt=yes \
21 --enable-threads=no \
22"
23
24PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
25PACKAGECONFIG[systemd] = "--enable-init=service.redhat --enable-initdir=${systemd_system_unitdir}, --enable-init=sysv.redhat, systemd"
26
27INITSCRIPT_PACKAGES = "${PN}"
28INITSCRIPT_NAME = "haveged"
29INITSCRIPT_PARAMS_${PN} = "defaults 9"
30
31SYSTEMD_PACKAGES = "${PN}"
32SYSTEMD_SERVICE_${PN} = "haveged.service"
33
34do_install_append() {
35 # The exit status is 143 when the service is stopped
36 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
37 sed -i '/ExecStart/a SuccessExitStatus=143' ${D}${systemd_system_unitdir}/haveged.service
Brad Bishop2f973922019-11-11 07:58:48 -050038 # Hybrid systemd-sysvinit distros must install the initscript manually
39 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
40 install -d ${D}${INIT_D_DIR}
41 sed -e "s,@SBINDIR@,${sbindir},g" <${S}/init.d/sysv.redhat >${D}${INIT_D_DIR}/haveged
42 chmod 755 ${D}${INIT_D_DIR}/haveged
43 fi
Brad Bishop19323692019-04-05 15:28:33 -040044 fi
45}
46
47MIPS_INSTRUCTION_SET = "mips"