blob: 36b056fdd5a1b2d0fd736426b1633467db028718 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "AbiWord is free word processing program similar to Microsoft(r) Word"
2HOMEPAGE = "http://www.abiword.org"
3SECTION = "x11/office"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20"
6DEPENDS = " \
7 perl-native \
8 gtk+ \
9 gtkmathview \
10 wv \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011 fribidi \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012 jpeg \
13 libpng \
14 librsvg \
15 libwmf-native \
16 asio \
17 evolution-data-server \
18 libxslt \
19 ${@bb.utils.contains('BBFILE_COLLECTIONS', 'office-layer', 'redland rasqal', '', d)} \
20"
21RDEPENDS_${PN}_append_libc-glibc = " \
22 glibc-gconv-ibm850 glibc-gconv-cp1252 \
23 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1 \
24"
25RCONFLICTS_${PN} = "${PN}-embedded"
26
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027SRC_URI = "http://www.abisource.com/downloads/${BPN}/${PV}/source/${BP}.tar.gz \
28 file://0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch \
29 file://0001-Bug-13770-Require-C-11-from-now-on.patch \
30 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050031
32LIC_FILES_CHKSUM = "file://COPYING;md5=c5edcc3ccd864b19004d14e9c1c9a26a"
33
34SRC_URI[md5sum] = "cda6dd58c747c133b421cc7eb18f5796"
35SRC_URI[sha256sum] = "afbfd458fd02989d8b0c6362ba8a4c14686d89666f54cfdb5501bd2090cf3522"
36
37#want 3.x from 3.x.y for the installation directory
38SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
39
Brad Bishop316dfdd2018-06-25 12:45:53 -040040inherit distro_features_check autotools-brokensep pkgconfig
41
42REQUIRED_DISTRO_FEATURES = "x11"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050043
44PACKAGECONFIG ??= " \
45 collab-backend-xmpp collab-backend-tcp \
46 ${@bb.utils.contains('BBFILE_COLLECTIONS', 'office-layer', 'libical', '', d)} \
47"
48PACKAGECONFIG[libical] = "--with-libical,--without-libical,libical raptor2"
49PACKAGECONFIG[spell] = "--enable-spell,--disable-spell,enchant"
50PACKAGECONFIG[collab-backend-xmpp] = "--enable-collab-backend-xmpp,--disable-collab-backend-xmpp,libgsf libxml2 loudmouth"
51PACKAGECONFIG[collab-backend-tcp] = "--enable-collab-backend-tcp,--disable-collab-backend-tcp,libgsf libxml2"
52PACKAGECONFIG[collab-backend-service] = "--enable-collab-backend-service,--disable-collab-backend-service,libgsf libxml2 libsoup-2.4 gnutls"
53PACKAGECONFIG[collab-backend-telepathy] = "--enable-collab-backend-telepathy,--disable-collab-backend-telepathy,libgsf libxml2 telepathy-glib telepathy-mission-control"
54PACKAGECONFIG[collab-backend-sugar] = "--enable-collab-backend-sugar,--disable-collab-backend-sugar,libgsf libxml2 dbus-glib"
55
56EXTRA_OECONF = " --disable-static \
57 --enable-plugins \
58 --enable-clipart \
59 --enable-templates \
60 --without-gnomevfs \
61 --with-gtk2 \
62 --with-libwmf-config=${STAGING_DIR} \
63"
64
65LDFLAGS += "-lgmodule-2.0"
66
67do_compile() {
68 cd goffice-bits2
69 make goffice-paths.h
70 make libgoffice.la
71 cd ${B}
72 oe_runmake
73}
74
75PACKAGES += " ${PN}-clipart ${PN}-strings ${PN}-systemprofiles ${PN}-templates "
76
77FILES_${PN} += " \
78 ${libdir}/lib${PN}-*.so \
79 ${datadir}/mime-info \
80 ${datadir}/icons/* \
81 ${datadir}/${PN}-${SHRT_VER}/glade \
82 ${datadir}/${PN}-${SHRT_VER}/scripts \
83 ${datadir}/${PN}-${SHRT_VER}/system.profile-en \
84 ${datadir}/${PN}-${SHRT_VER}/system.profile-en_GB \
85 ${datadir}/${PN}-${SHRT_VER}/templates/normal.awt \
86 ${datadir}/${PN}-${SHRT_VER}/templates/normal.awt-en_GB \
87 ${datadir}/${PN}-${SHRT_VER}/templates/Employee-Directory.awt \
88 ${datadir}/${PN}-${SHRT_VER}/templates/Business-Report.awt \
89 ${datadir}/${PN}-${SHRT_VER}/templates/Fax-Coversheet.awt \
90 ${datadir}/${PN}-${SHRT_VER}/templates/Resume.awt \
91 ${datadir}/${PN}-${SHRT_VER}/templates/Two-Columns.awt \
92 ${datadir}/${PN}-${SHRT_VER}/templates/Memo.awt \
93 ${datadir}/${PN}-${SHRT_VER}/templates/Press-Release.awt \
94 ${datadir}/${PN}-${SHRT_VER}/certs \
95 ${datadir}/${PN}-${SHRT_VER}/ui \
96 ${datadir}/${PN}-${SHRT_VER}/xsl* \
97 ${datadir}/${PN}-${SHRT_VER}/mime-info \
98 ${datadir}/${PN}-${SHRT_VER}/Pr*.xml \
99"
100
101# don't steal /usr/lib/libabiword-3.0.so from ${PN}
102# in this case it's needed in ${PN}
103FILES_${PN}-dev = " \
104 ${includedir} \
105 ${libdir}/pkgconfig \
106 ${libdir}/${PN}*.la \
107 ${libdir}/lib${PN}*.la \
108 ${libdir}/${PN}-${SHRT_VER}/plugins/*.la \
109"
110FILES_${PN}-dbg += "${libdir}/${PN}-${SHRT_VER}/plugins/.debug"
111FILES_${PN}-doc += "${datadir}/${PN}-*/readme*"
112
113FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/strings"
114FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/system.profile*"
115FILES_${PN}-clipart += "${datadir}/${PN}-${SHRT_VER}/clipart"
116FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/AbiWord/strings"
117FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/AbiWord/system.profile*"
118FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates"
119
120PACKAGES_DYNAMIC += "^${PN}-meta.* ^${PN}-plugin-.*"
121
122python populate_packages_prepend () {
123 abiword_libdir = d.expand('${libdir}/${PN}-${SHRT_VER}/plugins')
124 do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
125
126 metapkg = "abiword-meta"
127 d.setVar('ALLOW_EMPTY_' + metapkg, "1")
128 d.setVar('FILES_' + metapkg, "")
129 blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ]
130 metapkg_rdepends = []
131 packages = d.getVar('PACKAGES').split()
132 for pkg in packages[1:]:
133 if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"):
134 print("Modifying %s" % pkg)
135 metapkg_rdepends.append(pkg)
136 d.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends))
137 d.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package')
138 packages.append(metapkg)
139 d.setVar('PACKAGES', ' '.join(packages))
140}
141
142FILES_${PN}-plugin-openxml += "${datadir}/${PN}-${SHRT_VER}/omml_xslt"