blob: 7f2dca6b662be773055de6b53aa22f4dcc6085ac [file] [log] [blame]
Patrick Williams8b8bc412016-08-17 15:02:23 -05001DESCRIPTION = "This repository contains the source code for the ARM side \
2libraries used on Raspberry Pi. These typically are installed in /opt/vc/lib \
3and includes source for the ARM side code to interface to: EGL, mmal, GLESv2,\
4vcos, openmaxil, vchiq_arm, bcm_host, WFC, OpenVG."
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENCE;md5=0448d6488ef8cc380632b1569ee6d196"
7
Patrick Williams8b8bc412016-08-17 15:02:23 -05008PROVIDES = "virtual/libgles2 \
9 virtual/egl"
10
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011RPROVIDES_${PN} += "libgles2 egl libegl"
Patrick Williams8b8bc412016-08-17 15:02:23 -050012
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013COMPATIBLE_MACHINE = "^rpi$"
Patrick Williams8b8bc412016-08-17 15:02:23 -050014
15SRCBRANCH = "master"
16SRCFORK = "raspberrypi"
Brad Bishop316dfdd2018-06-25 12:45:53 -040017SRCREV = "11389772c79685442e0ab8aa9be8ad0e32703f68"
18
19# Use the date of the above commit as the package version. Update this when
20# SRCREV is changed.
21PV = "20180219"
Patrick Williams8b8bc412016-08-17 15:02:23 -050022
23SRC_URI = "\
24 git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \
25 file://0001-Allow-applications-to-set-next-resource-handle.patch \
26 file://0002-wayland-Add-support-for-the-Wayland-winsys.patch \
27 file://0003-wayland-Add-Wayland-example.patch \
28 file://0004-wayland-egl-Add-bcm_host-to-dependencies.patch \
29 file://0005-interface-remove-faulty-assert-to-make-weston-happy-.patch \
30 file://0006-zero-out-wl-buffers-in-egl_surface_free.patch \
31 file://0007-initialize-front-back-wayland-buffers.patch \
32 file://0008-Remove-RPC_FLUSH.patch \
33 file://0009-fix-cmake-dependency-race.patch \
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -060034 file://0010-Fix-for-framerate-with-nested-composition.patch \
35 file://0011-build-shared-library-for-vchostif.patch \
36 file://0012-implement-buffer-wrapping-interface-for-dispmanx.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050037 file://0013-Implement-triple-buffering-for-wayland.patch \
38 file://0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch \
39 file://0015-EGL-glplatform.h-define-EGL_CAST.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040040 file://0016-Allow-multiple-wayland-compositor-state-data-per-pro.patch \
Patrick Williams8b8bc412016-08-17 15:02:23 -050041"
42S = "${WORKDIR}/git"
43
44inherit cmake pkgconfig
45
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -060046ASNEEDED = ""
47
Patrick Williams8b8bc412016-08-17 15:02:23 -050048EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DCMAKE_EXE_LINKER_FLAGS='-Wl,--no-as-needed' \
49 -DVMCS_INSTALL_PREFIX=${exec_prefix} \
50"
51
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -060052EXTRA_OECMAKE_append_aarch64 = " -DARM64=ON "
53
54
Patrick Williams8b8bc412016-08-17 15:02:23 -050055PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
56
57PACKAGECONFIG[wayland] = "-DBUILD_WAYLAND=TRUE -DWAYLAND_SCANNER_EXECUTABLE:FILEPATH=${STAGING_BINDIR_NATIVE}/wayland-scanner,,wayland-native wayland"
58
59CFLAGS_append = " -fPIC"
60
61do_install_append () {
62 for f in `find ${D}${includedir}/interface/vcos/ -name "*.h"`; do
63 sed -i 's/include "vcos_platform.h"/include "pthreads\/vcos_platform.h"/g' ${f}
64 sed -i 's/include "vcos_futex_mutex.h"/include "pthreads\/vcos_futex_mutex.h"/g' ${f}
65 sed -i 's/include "vcos_platform_types.h"/include "pthreads\/vcos_platform_types.h"/g' ${f}
66 done
67}
68
69# Shared libs from userland package build aren't versioned, so we need
70# to force the .so files into the runtime package (and keep them
71# out of -dev package).
72FILES_SOLIBSDEV = ""
73INSANE_SKIP_${PN} += "dev-so"
74
75FILES_${PN} += " \
76 ${libdir}/*.so \
77 ${libdir}/plugins"
78FILES_${PN}-dev += "${includedir} \
79 ${prefix}/src"
80FILES_${PN}-doc += "${datadir}/install"
81FILES_${PN}-dbg += "${libdir}/plugins/.debug"
82
83PACKAGE_ARCH = "${MACHINE_ARCH}"
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -060084
85RDEPENDS_${PN} += "bash"