blob: 77291c22ce572d933b6e09a0adec38972c6f6ddf [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Copyright (C) 2013 Intel Corporation
2#
3# Released under the MIT license (see COPYING.MIT)
4
5
6# testimage.bbclass enables testing of qemu images using python unittests.
7# Most of the tests are commands run on target image over ssh.
8# To use it add testimage to global inherit and call your target image with -c testimage
9# You can try it out like this:
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010# - first add IMAGE_CLASSES += "testimage" in local.conf
11# - build a qemu core-image-sato
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012# - then bitbake core-image-sato -c testimage. That will run a standard suite of tests.
13
14# You can set (or append to) TEST_SUITES in local.conf to select the tests
15# which you want to run for your target.
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016# The test names are the module names in meta/lib/oeqa/runtime/cases.
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017# Each name in TEST_SUITES represents a required test for the image. (no skipping allowed)
18# Appending "auto" means that it will try to run all tests that are suitable for the image (each test decides that on it's own).
19# Note that order in TEST_SUITES is relevant: tests are run in an order such that
20# tests mentioned in @skipUnlessPassed run before the tests that depend on them,
21# but without such dependencies, tests run in the order in which they are listed
22# in TEST_SUITES.
23#
24# A layer can add its own tests in lib/oeqa/runtime, provided it extends BBPATH as normal in its layer.conf.
25
26# TEST_LOG_DIR contains a command ssh log and may contain infromation about what command is running, output and return codes and for qemu a boot log till login.
27# Booting is handled by this class, and it's not a test in itself.
28# TEST_QEMUBOOT_TIMEOUT can be used to set the maximum time in seconds the launch code will wait for the login prompt.
29
30TEST_LOG_DIR ?= "${WORKDIR}/testimage"
31
32TEST_EXPORT_DIR ?= "${TMPDIR}/testimage/${PN}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060033TEST_INSTALL_TMP_DIR ?= "${WORKDIR}/testimage/install_tmp"
34TEST_NEEDED_PACKAGES_DIR ?= "${WORKDIR}/testimage/packages"
35TEST_EXTRACTED_DIR ?= "${TEST_NEEDED_PACKAGES_DIR}/extracted"
36TEST_PACKAGED_DIR ?= "${TEST_NEEDED_PACKAGES_DIR}/packaged"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050037
Brad Bishop6e60e8b2018-02-01 10:27:11 -050038RPMTESTSUITE = "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'dnf rpm', '', d)}"
39SYSTEMDSUITE = "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050040MINTESTSUITE = "ping"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050041NETTESTSUITE = "${MINTESTSUITE} ssh df date scp oe_syslog ${SYSTEMDSUITE}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050042DEVTESTSUITE = "gcc kernelmodule ldd"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050043
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050044DEFAULT_TEST_SUITES = "${MINTESTSUITE} auto"
45DEFAULT_TEST_SUITES_pn-core-image-minimal = "${MINTESTSUITE}"
46DEFAULT_TEST_SUITES_pn-core-image-minimal-dev = "${MINTESTSUITE}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040047DEFAULT_TEST_SUITES_pn-core-image-full-cmdline = "${NETTESTSUITE} perl python logrotate ptest"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050048DEFAULT_TEST_SUITES_pn-core-image-x11 = "${MINTESTSUITE}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040049DEFAULT_TEST_SUITES_pn-core-image-lsb = "${NETTESTSUITE} pam parselogs ${RPMTESTSUITE} ptest"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050050DEFAULT_TEST_SUITES_pn-core-image-sato = "${NETTESTSUITE} connman xorg parselogs ${RPMTESTSUITE} \
Brad Bishop316dfdd2018-06-25 12:45:53 -040051 ${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'python', '', d)} ptest gi"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050052DEFAULT_TEST_SUITES_pn-core-image-sato-sdk = "${NETTESTSUITE} buildcpio buildlzip buildgalculator \
Brad Bishop316dfdd2018-06-25 12:45:53 -040053 connman ${DEVTESTSUITE} logrotate perl parselogs python ${RPMTESTSUITE} xorg ptest gi stap"
54DEFAULT_TEST_SUITES_pn-core-image-lsb-dev = "${NETTESTSUITE} pam perl python parselogs ${RPMTESTSUITE} ptest gi"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050055DEFAULT_TEST_SUITES_pn-core-image-lsb-sdk = "${NETTESTSUITE} buildcpio buildlzip buildgalculator \
Brad Bishop316dfdd2018-06-25 12:45:53 -040056 connman ${DEVTESTSUITE} logrotate pam parselogs perl python ${RPMTESTSUITE} ptest gi stap"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050057DEFAULT_TEST_SUITES_pn-meta-toolchain = "auto"
58
59# aarch64 has no graphics
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050060DEFAULT_TEST_SUITES_remove_aarch64 = "xorg"
Brad Bishop316dfdd2018-06-25 12:45:53 -040061# musl doesn't support systemtap
62DEFAULT_TEST_SUITES_remove_libc-musl = "stap"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050063
Patrick Williamsc0f7c042017-02-23 20:41:17 -060064# qemumips is quite slow and has reached the timeout limit several times on the YP build cluster,
65# mitigate this by removing build tests for qemumips machines.
Brad Bishopd7bf8c12018-02-25 22:55:05 -050066MIPSREMOVE ??= "buildcpio buildlzip buildgalculator"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060067DEFAULT_TEST_SUITES_remove_qemumips = "${MIPSREMOVE}"
68DEFAULT_TEST_SUITES_remove_qemumips64 = "${MIPSREMOVE}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050069
70TEST_SUITES ?= "${DEFAULT_TEST_SUITES}"
71
72TEST_QEMUBOOT_TIMEOUT ?= "1000"
73TEST_TARGET ?= "qemu"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050074
75TESTIMAGEDEPENDS = ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -050076TESTIMAGEDEPENDS_qemuall = "qemu-native:do_populate_sysroot qemu-helper-native:do_populate_sysroot qemu-helper-native:do_addto_recipe_sysroot"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060077TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'cpio-native:do_populate_sysroot', '', d)}"
78TESTIMAGEDEPENDS_qemuall += "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'cpio-native:do_populate_sysroot', '', d)}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050079TESTIMAGEDEPENDS_qemuall += "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'createrepo-c-native:do_populate_sysroot', '', d)}"
80TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'dnf-native:do_populate_sysroot', '', d)}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060081TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'ipk', 'opkg-utils-native:do_populate_sysroot', '', d)}"
82TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'deb', 'apt-native:do_populate_sysroot', '', d)}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050083TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'createrepo-c-native:do_populate_sysroot', '', d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050084
85TESTIMAGELOCK = "${TMPDIR}/testimage.lock"
86TESTIMAGELOCK_qemuall = ""
87
88TESTIMAGE_DUMP_DIR ?= "/tmp/oe-saved-tests/"
89
Brad Bishop6e60e8b2018-02-01 10:27:11 -050090TESTIMAGE_UPDATE_VARS ?= "DL_DIR WORKDIR DEPLOY_DIR"
91
Patrick Williamsc124f4f2015-09-15 14:41:29 -050092testimage_dump_target () {
93 top -bn1
94 ps
95 free
96 df
97 # The next command will export the default gateway IP
98 export DEFAULT_GATEWAY=$(ip route | awk '/default/ { print $3}')
99 ping -c3 $DEFAULT_GATEWAY
100 dmesg
101 netstat -an
102 ip address
103 # Next command will dump logs from /var/log/
104 find /var/log/ -type f 2>/dev/null -exec echo "====================" \; -exec echo {} \; -exec echo "====================" \; -exec cat {} \; -exec echo "" \;
105}
106
107testimage_dump_host () {
108 top -bn1
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500109 iostat -x -z -N -d -p ALL 20 2
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500110 ps -ef
111 free
112 df
113 memstat
114 dmesg
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500115 ip -s link
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500116 netstat -an
117}
118
119python do_testimage() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500120
121 testimage_sanity(d)
122
123 if (d.getVar('IMAGE_PKGTYPE') == 'rpm'
124 and 'dnf' in d.getVar('TEST_SUITES')):
125 create_rpm_index(d)
126
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500127 testimage_main(d)
128}
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600129
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500130addtask testimage
131do_testimage[nostamp] = "1"
132do_testimage[depends] += "${TESTIMAGEDEPENDS}"
133do_testimage[lockfiles] += "${TESTIMAGELOCK}"
134
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500135def testimage_sanity(d):
136 if (d.getVar('TEST_TARGET') == 'simpleremote'
137 and (not d.getVar('TEST_TARGET_IP')
138 or not d.getVar('TEST_SERVER_IP'))):
139 bb.fatal('When TEST_TARGET is set to "simpleremote" '
140 'TEST_TARGET_IP and TEST_SERVER_IP are needed too.')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500141
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500142def testimage_main(d):
143 import os
144 import json
145 import signal
146 import logging
147
148 from bb.utils import export_proxies
149 from oeqa.core.utils.misc import updateTestData
150 from oeqa.runtime.context import OERuntimeTestContext
151 from oeqa.runtime.context import OERuntimeTestContextExecutor
152 from oeqa.core.target.qemu import supported_fstypes
153 from oeqa.core.utils.test import getSuiteCases
154 from oeqa.utils import make_logger_bitbake_compatible
155
156 def sigterm_exception(signum, stackframe):
157 """
158 Catch SIGTERM from worker in order to stop qemu.
159 """
160 raise RuntimeError
161
162 logger = make_logger_bitbake_compatible(logging.getLogger("BitBake"))
163 pn = d.getVar("PN")
164
165 bb.utils.mkdirhier(d.getVar("TEST_LOG_DIR"))
166
167 image_name = ("%s/%s" % (d.getVar('DEPLOY_DIR_IMAGE'),
168 d.getVar('IMAGE_LINK_NAME')))
169
170 tdname = "%s.testdata.json" % image_name
171 try:
172 td = json.load(open(tdname, "r"))
173 except (FileNotFoundError) as err:
174 bb.fatal('File %s Not Found. Have you built the image with INHERIT+="testimage" in the conf/local.conf?' % tdname)
175
176 # Some variables need to be updates (mostly paths) with the
177 # ones of the current environment because some tests require them.
178 updateTestData(d, td, d.getVar('TESTIMAGE_UPDATE_VARS').split())
179
180 image_manifest = "%s.manifest" % image_name
181 image_packages = OERuntimeTestContextExecutor.readPackagesManifest(image_manifest)
182
183 extract_dir = d.getVar("TEST_EXTRACTED_DIR")
184
185 # Get machine
186 machine = d.getVar("MACHINE")
187
188 # Get rootfs
189 fstypes = [fs for fs in d.getVar('IMAGE_FSTYPES').split(' ')
190 if fs in supported_fstypes]
191 if not fstypes:
192 bb.fatal('Unsupported image type built. Add a comptible image to '
193 'IMAGE_FSTYPES. Supported types: %s' %
194 ', '.join(supported_fstypes))
195 rootfs = '%s.%s' % (image_name, fstypes[0])
196
197 # Get tmpdir (not really used, just for compatibility)
198 tmpdir = d.getVar("TMPDIR")
199
200 # Get deploy_dir_image (not really used, just for compatibility)
201 dir_image = d.getVar("DEPLOY_DIR_IMAGE")
202
203 # Get bootlog
204 bootlog = os.path.join(d.getVar("TEST_LOG_DIR"),
205 'qemu_boot_log.%s' % d.getVar('DATETIME'))
206
207 # Get display
208 display = d.getVar("BB_ORIGENV").getVar("DISPLAY")
209
210 # Get kernel
211 kernel_name = ('%s-%s.bin' % (d.getVar("KERNEL_IMAGETYPE"), machine))
212 kernel = os.path.join(d.getVar("DEPLOY_DIR_IMAGE"), kernel_name)
213
214 # Get boottime
215 boottime = int(d.getVar("TEST_QEMUBOOT_TIMEOUT"))
216
217 # Get use_kvm
218 qemu_use_kvm = d.getVar("QEMU_USE_KVM")
219 if qemu_use_kvm and \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400220 (oe.types.boolean(qemu_use_kvm) and 'x86' in machine or \
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500221 d.getVar('MACHINE') in qemu_use_kvm.split()):
222 kvm = True
223 else:
224 kvm = False
225
226 # TODO: We use the current implementatin of qemu runner because of
227 # time constrains, qemu runner really needs a refactor too.
228 target_kwargs = { 'machine' : machine,
229 'rootfs' : rootfs,
230 'tmpdir' : tmpdir,
231 'dir_image' : dir_image,
232 'display' : display,
233 'kernel' : kernel,
234 'boottime' : boottime,
235 'bootlog' : bootlog,
236 'kvm' : kvm,
237 }
238
239 # TODO: Currently BBPATH is needed for custom loading of targets.
240 # It would be better to find these modules using instrospection.
241 target_kwargs['target_modules_path'] = d.getVar('BBPATH')
242
243 # runtime use network for download projects for build
244 export_proxies(d)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500245
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500246 # we need the host dumper in test context
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500247 host_dumper = OERuntimeTestContextExecutor.getHostDumper(
248 d.getVar("testimage_dump_host"),
249 d.getVar("TESTIMAGE_DUMP_DIR"))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500250
251 # the robot dance
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500252 target = OERuntimeTestContextExecutor.getTarget(
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500253 d.getVar("TEST_TARGET"), logger, d.getVar("TEST_TARGET_IP"),
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500254 d.getVar("TEST_SERVER_IP"), **target_kwargs)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500255
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500256 # test context
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500257 tc = OERuntimeTestContext(td, logger, target, host_dumper,
258 image_packages, extract_dir)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500259
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500260 # Load tests before starting the target
261 test_paths = get_runtime_paths(d)
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500262 test_modules = d.getVar('TEST_SUITES').split()
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500263 tc.loadTests(test_paths, modules=test_modules)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500264
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500265 if not getSuiteCases(tc.suites):
266 bb.fatal('Empty test suite, please verify TEST_SUITES variable')
267
268 package_extraction(d, tc.suites)
269
270 bootparams = None
271 if d.getVar('VIRTUAL-RUNTIME_init_manager', '') == 'systemd':
272 # Add systemd.log_level=debug to enable systemd debug logging
273 bootparams = 'systemd.log_target=console'
274
275 results = None
276 orig_sigterm_handler = signal.signal(signal.SIGTERM, sigterm_exception)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600277 try:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500278 # We need to check if runqemu ends unexpectedly
279 # or if the worker send us a SIGTERM
280 tc.target.start(extra_bootparams=bootparams)
281 results = tc.runTests()
282 except (RuntimeError, BlockingIOError) as err:
283 if isinstance(err, RuntimeError):
284 bb.error('testimage received SIGTERM, shutting down...')
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600285 else:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500286 bb.error('runqemu failed, shutting down...')
287 if results:
288 results.stop()
289 results = None
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600290 finally:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500291 signal.signal(signal.SIGTERM, orig_sigterm_handler)
292 tc.target.stop()
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600293
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500294 # Show results (if we have them)
295 if not results:
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500296 bb.fatal('%s - FAILED - tests were interrupted during execution' % pn, forcelog=True)
297 results.logDetails()
298 results.logSummary(pn)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500299 if not results.wasSuccessful():
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500300 bb.fatal('%s - FAILED - check the task log and the ssh log' % pn, forcelog=True)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600301
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500302def get_runtime_paths(d):
303 """
304 Returns a list of paths where runtime test must reside.
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500305
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500306 Runtime tests are expected in <LAYER_DIR>/lib/oeqa/runtime/cases/
307 """
308 paths = []
309
310 for layer in d.getVar('BBLAYERS').split():
311 path = os.path.join(layer, 'lib/oeqa/runtime/cases')
312 if os.path.isdir(path):
313 paths.append(path)
314 return paths
315
316def create_index(arg):
317 import subprocess
318
319 index_cmd = arg
320 try:
321 bb.note("Executing '%s' ..." % index_cmd)
322 result = subprocess.check_output(index_cmd,
323 stderr=subprocess.STDOUT,
324 shell=True)
325 result = result.decode('utf-8')
326 except subprocess.CalledProcessError as e:
327 return("Index creation command '%s' failed with return code "
328 '%d:\n%s' % (e.cmd, e.returncode, e.output.decode("utf-8")))
329 if result:
330 bb.note(result)
331 return None
332
333def create_rpm_index(d):
334 # Index RPMs
335 rpm_createrepo = bb.utils.which(os.getenv('PATH'), "createrepo_c")
336 index_cmds = []
337 archs = (d.getVar('ALL_MULTILIB_PACKAGE_ARCHS') or '').replace('-', '_')
338
339 for arch in archs.split():
340 rpm_dir = os.path.join(d.getVar('DEPLOY_DIR_RPM'), arch)
341 idx_path = os.path.join(d.getVar('WORKDIR'), 'oe-testimage-repo', arch)
342
343 if not os.path.isdir(rpm_dir):
344 continue
345
346 lockfilename = os.path.join(d.getVar('DEPLOY_DIR_RPM'), 'rpm.lock')
347 lf = bb.utils.lockfile(lockfilename, False)
348 oe.path.copyhardlinktree(rpm_dir, idx_path)
349 # Full indexes overload a 256MB image so reduce the number of rpms
350 # in the feed. Filter to r* since we use the run-postinst packages and
351 # this leaves some allarch and machine arch packages too.
352 bb.utils.remove(idx_path + "*/[a-qs-z]*.rpm")
353 bb.utils.unlockfile(lf)
354 cmd = '%s --update -q %s' % (rpm_createrepo, idx_path)
355
356 # Create repodata
357 result = create_index(cmd)
358 if result:
359 bb.fatal('%s' % ('\n'.join(result)))
360
361def package_extraction(d, test_suites):
362 from oeqa.utils.package_manager import find_packages_to_extract
363 from oeqa.utils.package_manager import extract_packages
364
365 bb.utils.remove(d.getVar("TEST_NEEDED_PACKAGES_DIR"), recurse=True)
366 packages = find_packages_to_extract(test_suites)
367 if packages:
368 bb.utils.mkdirhier(d.getVar("TEST_INSTALL_TMP_DIR"))
369 bb.utils.mkdirhier(d.getVar("TEST_PACKAGED_DIR"))
370 bb.utils.mkdirhier(d.getVar("TEST_EXTRACTED_DIR"))
371 extract_packages(d, packages)
372
373testimage_main[vardepsexclude] += "BB_ORIGENV DATETIME"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500374
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500375inherit testsdk