blob: d9da1905782da78dd8bf80946415a0e53559479b [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A New System Troubleshooting Tool Built for the Way You Work"
2DESCRIPTION = "Sysdig is open source, system-level exploration: capture \
3system state and activity from a running Linux instance, then save, \
4filter and analyze."
5HOMEPAGE = "http://www.sysdig.org/"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006LICENSE = "Apache-2.0 & (MIT | GPL-2.0)"
7LIC_FILES_CHKSUM = "file://COPYING;md5=f8fee3d59797546cffab04f3b88b2d44"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05008
9inherit cmake pkgconfig
10
Andrew Geissler82c905d2020-04-13 13:39:40 -050011#OECMAKE_GENERATOR = "Unix Makefiles"
12JIT ?= "jit"
13JIT_mipsarchn32 = ""
14JIT_mipsarchn64 = ""
15JIT_riscv64 = ""
16JIT_riscv32 = ""
Brad Bishop316dfdd2018-06-25 12:45:53 -040017
Andrew Geissler32b11992021-03-31 13:37:05 -050018DEPENDS += "libb64 lua${JIT} zlib c-ares grpc-native grpc curl ncurses jsoncpp tbb jq openssl elfutils protobuf protobuf-native jq-native"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050019RDEPENDS_${PN} = "bash"
20
Andrew Geissler82c905d2020-04-13 13:39:40 -050021SRC_URI = "git://github.com/draios/sysdig.git;branch=dev \
22 file://0001-fix-build-with-LuaJIT-2.1-betas.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050023 file://aarch64.patch \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050024 "
Andrew Geissler32b11992021-03-31 13:37:05 -050025SRCREV = "67833b2aca06bd9d11cff7cb29f04fbf4ef96cad"
26PV = "0.27.1"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050027
28S = "${WORKDIR}/git"
29
Andrew Geissler82c905d2020-04-13 13:39:40 -050030EXTRA_OECMAKE = "\
31 -DBUILD_DRIVER=OFF \
32 -DUSE_BUNDLED_DEPS=OFF \
Andrew Geissler82c905d2020-04-13 13:39:40 -050033 -DCREATE_TEST_TARGETS=OFF \
34 -DDIR_ETC=${sysconfdir} \
35 -DLUA_INCLUDE_DIR=${STAGING_INCDIR}/luajit-2.1 \
36 -DLUA_LIBRARY=libluajit-5.1.so \
37"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050038
39FILES_${PN} += " \
40 ${DIR_ETC}/* \
Patrick Williamsddad1a12017-02-23 20:36:32 -060041 ${datadir}/zsh/* \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050042 ${prefix}/src/* \
43"
Andrew Geissler82c905d2020-04-13 13:39:40 -050044# Use getaddrinfo_a is a GNU extension in libsinsp
45# It should be fixed in sysdig, until then disable
46# on musl
47# Something like this https://code.videolan.org/ePirat/vlc/-/commit/01fd9fe4c7f6c5558f7345f38abf0152e17853ab is needed to fix it
48COMPATIBLE_HOST_libc-musl = "null"
49COMPATIBLE_HOST_mips = "null"
50COMPATIBLE_HOST_riscv64 = "null"
51COMPATIBLE_HOST_riscv32 = "null"