blob: a1941bf3cbdb300c7a4f0f36cd555a3b05d337ba [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "DataStax Python Driver for Apache Cassandra"
2DESCRIPTION = "A modern, feature-rich and highly-tunable Python client \
3library for Apache Cassandra (1.2+) and DataStax Enterprise (3.1+) using \
4exclusively Cassandra's binary protocol and Cassandra Query Language v3."
5HOMEPAGE = "https://github.com/datastax/python-driver"
6SECTION = "devel/python"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
9SRCNAME = "cassandra-driver"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010
Andrew Geissler32b11992021-03-31 13:37:05 -050011SRC_URI[sha256sum] = "8ad7d7c090eb1cac6110b3bfc1fd2d334ac62f415aac09350ebb8d241b7aa7ee"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
13DISTUTILS_BUILD_ARGS += " \
14 --no-libev \
15"
16DISTUTILS_INSTALL_ARGS += " \
17 --no-libev \
18"
19
20inherit pypi setuptools3
21
22RDEPENDS_${PN} += "\
23 ${PYTHON_PN}-cython \
24 ${PYTHON_PN}-json \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025 ${PYTHON_PN}-misc \
Andrew Geissler82c905d2020-04-13 13:39:40 -050026 ${PYTHON_PN}-multiprocessing \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027 ${PYTHON_PN}-numbers \
Andrew Geissler82c905d2020-04-13 13:39:40 -050028 ${PYTHON_PN}-six \
29 libevent \
30"
31
32DEPENDS += "\
33 ${PYTHON_PN}-cython \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050034"