blob: 13cef537e2a79ea2e4ff8c06d71013adf756b9d4 [file] [log] [blame]
Andrew Geissler97771a32021-03-05 15:23:11 -06001DESCRIPTION = "Google gRPC"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7DEPENDS += "${PYTHON_PN}-protobuf"
8
9SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
10SRC_URI_append_class-target = " file://ppc-boringssl-support.patch \
11 file://riscv64_support.patch \
12 file://boring_ssl.patch \
Andrew Geissler32b11992021-03-31 13:37:05 -050013 file://mips_bigendian.patch \
14 file://0001-absl-always-use-asm-sgidefs.h.patch \
Andrew Geissler97771a32021-03-05 15:23:11 -060015"
Andrew Geissler32b11992021-03-31 13:37:05 -050016SRC_URI[sha256sum] = "a66ea59b20f3669df0f0c6a3bd57b985e5b2d1dcf3e4c29819bb8dc232d0fd38"
Andrew Geissler97771a32021-03-05 15:23:11 -060017
18RDEPENDS_${PN} = "${PYTHON_PN}-protobuf \
19 ${PYTHON_PN}-setuptools \
20 ${PYTHON_PN}-six \
21"
22
23inherit setuptools3
24inherit pypi
25
26export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY = "1"
27
28BORING_SSL_PLATFORM_arm = "linux-arm"
29BORING_SSL_PLATFORM_x86-64 = "linux-x86_64"
30BORING_SSL_PLATFORM ?= "unsupported"
31export GRPC_BORING_SSL_PLATFORM = "${BORING_SSL_PLATFORM}"
32
33BORING_SSL_x86-64 = "1"
34BORING_SSL_arm = "1"
35BORING_SSL ?= "0"
36export GRPC_BUILD_WITH_BORING_SSL_ASM = "${BORING_SSL}"
37
38GRPC_CFLAGS_append_toolchain-clang = " -fvisibility=hidden -fno-wrapv -fno-exceptions"
39export GRPC_PYTHON_CFLAGS = "${GRPC_CFLAGS}"
40
41CLEANBROKEN = "1"
42
43BBCLASSEXTEND = "native nativesdk"
44
45CCACHE_DISABLE = "1"
Andrew Geissler32b11992021-03-31 13:37:05 -050046
47# needs vdso support
48COMPATIBLE_HOST_libc-musl_powerpc64le = "null"
49