blob: ff8fab31f4e10461f0272a939edd1f387fafefd8 [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001DESCRIPTION = "Incremental is a small library that versions your Python projects"
2HOMEPAGE = "https://github.com/twisted/incremental"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=6ca9b07f08e2c72d48c74d363d1e0e15"
5
Andrew Geissler32b11992021-03-31 13:37:05 -05006SRC_URI[sha256sum] = "02f5de5aff48f6b9f665d99d48bfc7ec03b6e3943210de7cfc88856d755d6f57"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05007
8inherit pypi setuptools3
9
10RDEPENDS_${PN} += " \
11 ${PYTHON_PN}-twisted \
12 ${PYTHON_PN}-click \
13"
14
15# -native is needed to build python[3]-twisted, however, we need to take steps to
16# prevent a circular dependency. The build apparently does not use the part of
17# python-incremental which uses python-twisted, so this hack is OK.
18RDEPENDS_${PYTHON_PN}-incremental-native_remove = "${PYTHON_PN}-twisted-native"
19BBCLASSEXTEND = "native"