blob: 0da2c6607c618e562a6a6ffff9ac9188fecefe30 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Dependency management tool for Golang"
2HOMEPAGE = "https://github.com/golang/dep"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=1bad315647751fab0007812f70d42c0d"
5
6GO_IMPORT = "github.com/golang/dep"
7SRC_URI = "git://${GO_IMPORT} \
8 file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \
Andrew Geissler82c905d2020-04-13 13:39:40 -05009 file://0001-bolt_riscv64-Add-support-for-riscv64.patch;patchdir=src/github.com/golang/dep \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010 "
Andrew Geisslerb7d28612020-07-24 16:15:54 -050011SRC_URI_append_riscv64 = " file://0001-Update-sys-module-to-latest.patch;patchdir=src/github.com/golang/dep "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012
Brad Bishop79641f22019-09-10 07:20:22 -040013SRCREV = "1f7c19e5f52f49ffb9f956f64c010be14683468b"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014
15inherit go
16
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050017# New Go versions has Go modules support enabled by default and cause the Glide
18# tool build to fail.
19export GO111MODULE = "off"
20
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021GO_INSTALL = "${GO_IMPORT}/cmd/dep"
22
23RDEPENDS_${PN}-dev += "bash"
24
25BBCLASSEXTEND = "native nativesdk"
26
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027# For compiling ptest on mips and mips64, the current go-dep version fails with the go 1.11 toolchain.
28# error message: vet config not found
29PTEST_ENABLED_mips = "0"
30PTEST_ENABLED_mips64 = "0"