Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "GNOME Shell is the graphical shell of the GNOME desktop environment" |
| 2 | LICENSE = "GPL-2.0-only" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 4 | |
| 5 | GNOMEBASEBUILDCLASS = "meson" |
| 6 | |
| 7 | DEPENDS = " \ |
| 8 | libxml2-native \ |
| 9 | gtk4 \ |
| 10 | mutter \ |
| 11 | evolution-data-server \ |
| 12 | gcr \ |
| 13 | geocode-glib \ |
| 14 | gjs \ |
| 15 | gnome-autoar \ |
| 16 | polkit \ |
| 17 | libcroco \ |
| 18 | libsoup-3.0 \ |
| 19 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', 'startup-notification', d)} \ |
| 20 | ibus \ |
| 21 | gsettings-desktop-schemas \ |
| 22 | " |
| 23 | |
| 24 | inherit gnomebase gsettings gettext gobject-introspection gtk-icon-cache features_check bash-completion |
| 25 | |
| 26 | REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam" |
| 27 | |
| 28 | GTKIC_VERSION = "4" |
| 29 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 30 | GIR_MESON_OPTION = "" |
| 31 | |
| 32 | # gobject-introspection is mandatory and cannot be configured |
| 33 | REQUIRED_DISTRO_FEATURES += "gobject-introspection-data" |
| 34 | |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 35 | SRC_URI[archive.sha256sum] = "55694b71c2ee4eaef60d93428003f2eaa4cf00186848f5e36b45cfe506fc31bf" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 36 | SRC_URI += "file://0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch" |
| 37 | |
| 38 | PACKAGECONFIG ??= "bluetooth nm ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 39 | PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth" |
| 40 | PACKAGECONFIG[nm] = "-Dnetworkmanager=true, -Dnetworkmanager=false,networkmanager,networkmanager" |
| 41 | PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd" |
| 42 | |
| 43 | EXTRA_OEMESON = " \ |
| 44 | -Dgjs_path=${bindir}/gjs \ |
| 45 | -Dextensions-app:gjs_path=${bindir}/gjs \ |
| 46 | -Dtests=false \ |
| 47 | -Dman=false \ |
| 48 | -Dsoup2=false \ |
| 49 | " |
| 50 | |
| 51 | do_install:append() { |
| 52 | # fix shebangs |
| 53 | for tool in `find ${D}${bindir} -name '*-tool'`; do |
| 54 | sed -i 's:#!${PYTHON}:#!${bindir}/${PYTHON_PN}:' $tool |
| 55 | done |
| 56 | } |
| 57 | |
| 58 | GSETTINGS_PACKAGE = "${PN}-gsettings" |
| 59 | |
| 60 | FILES:${PN} += " \ |
| 61 | ${datadir}/metainfo \ |
| 62 | ${datadir}/dbus-1 \ |
| 63 | ${datadir}/gnome-control-center \ |
| 64 | ${datadir}/xdg-desktop-portal \ |
| 65 | ${systemd_user_unitdir} \ |
| 66 | " |
| 67 | |
| 68 | RDEPENDS:${PN} += " \ |
| 69 | accountsservice \ |
| 70 | adwaita-icon-theme \ |
| 71 | adwaita-icon-theme-cursors \ |
| 72 | gdm-base \ |
| 73 | gnome-control-center \ |
| 74 | gnome-backgrounds \ |
| 75 | gnome-bluetooth \ |
| 76 | gnome-desktop \ |
| 77 | gnome-session \ |
| 78 | gnome-settings-daemon \ |
| 79 | gnome-shell-gsettings \ |
| 80 | gsettings-desktop-schemas \ |
| 81 | librsvg-gtk \ |
| 82 | " |
| 83 | |
| 84 | PACKAGES =+ "${PN}-tools ${PN}-gsettings" |
| 85 | FILES:${PN}-tools = "${bindir}/*-tool" |
| 86 | RDEPENDS:${PN}-tools = "python3-core" |
| 87 | |