Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 1 | SUMMARY = "File system check utility for OverlayFS" |
| 2 | HOMEPAGE = "https://github.com/hisilicon/overlayfs-progs" |
| 3 | LICENSE = "PD" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/PD;md5=b3597d12946881e13cb3b548d1173851" |
| 5 | |
| 6 | SRC_URI = "\ |
| 7 | git://github.com/hisilicon/overlayfs-progs.git;protocol=https;branch=master \ |
| 8 | file://0001-Makefile-proper-location-of-LDFLAGS.patch \ |
| 9 | " |
| 10 | |
| 11 | PV = "1.0+git${SRCPV}" |
| 12 | SRCREV = "e10ef686570d9c7eff42f52461593a5c15da56bd" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | B = "${S}" |
| 16 | |
| 17 | # Required to have the fts.h header for musl |
| 18 | DEPENDS:append:libc-musl = " fts" |
| 19 | # Fix the missing fts libs when using musl |
| 20 | EXTRA_OEMAKE:append:libc-musl = " LDFLAGS='-lfts'" |
| 21 | |
| 22 | EXTRA_OEMAKE += "'CC=${CC} -O2' " |
| 23 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 24 | |
| 25 | do_compile () { |
| 26 | oe_runmake |
| 27 | } |
| 28 | |
| 29 | do_install () { |
| 30 | install -d ${D}${bindir} |
| 31 | install -m 0755 ${B}/fsck.overlay ${D}${bindir} |
| 32 | } |