blob: 02c655258bb79cb93bb7a4f96dba1fa130eee721 [file] [log] [blame]
Patrick Williams1e5b4ec2017-01-30 11:05:56 -06001SUMMARY = "Phosphor DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the phosphor YAML"
Brad Bishop75f03872018-11-03 09:41:57 -07003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Ed Tanous9936f862022-09-19 09:13:20 -07005DEPENDS += " \
6 ${PYTHON_PN}-sdbus++-native \
7 sdbusplus \
8 systemd \
9 "
Andrew Geissler32fdca12023-01-24 13:40:21 -060010SRCREV = "d1d7824e1768073337e28bac78cf7462a8d8c1e7"
Ed Tanous9936f862022-09-19 09:13:20 -070011PV = "1.0+git${SRCPV}"
12PR = "r1"
13
14SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces;branch=master;protocol=https"
15
16S = "${WORKDIR}/git"
Patrick Williams1e5b4ec2017-01-30 11:05:56 -060017
Andrew Geisslerec34cc62021-11-03 09:57:52 -050018inherit pkgconfig meson
Patrick Williams56d37042020-09-08 16:51:14 -050019inherit obmc-phosphor-utils
Marri Devender Rao8dd77982017-05-29 01:33:26 -050020inherit phosphor-dbus-yaml
Patrick Williams56d37042020-09-08 16:51:14 -050021inherit python3native
Patrick Williams1e5b4ec2017-01-30 11:05:56 -060022
Ed Tanous9936f862022-09-19 09:13:20 -070023# Markdown files are installed into /usr/share/phosphor-dbus-interfaces so
24# add them to the 'doc' subpackage.
25FILES:${PN}-doc += "${datadir}/${BPN}"
Patrick Williams56d37042020-09-08 16:51:14 -050026
27# Process OBMC_ORG_YAML_SUBDIRS to create Meson config options.
28# ex. xyz/openbmc_project -> -Ddata_xyz_openbmc_project=true
29def pdi_meson_config(d):
30 return ' '.join([
31 '-Ddata_' + x.replace('/', '_') + '=true' \
32 for x in listvar_to_list(d, 'OBMC_ORG_YAML_SUBDIRS')
33 ])
Patrick Williamsbec9f782020-09-15 10:33:02 -050034pdi_meson_config[vardeps] = "OBMC_ORG_YAML_SUBDIRS"
William A. Kennington III9f8cb032022-03-07 16:51:43 -080035EXTRA_OEMESON += "${@pdi_meson_config(d)}"
William A. Kennington III9f8cb032022-03-07 16:51:43 -080036# Remove all schemas by default regardless of the meson_options.txt config
37do_write_config:append() {
38 for intf in $(grep "^option('data_" ${S}/meson_options.txt | sed "s,^.*\(data_[^']*\).*$,\1,"); do
39 sed -i "/^\[built-in options\]\$/a$intf = false" ${WORKDIR}/meson.cross
40 done
41}
Patrick Williamsd5ed0922023-01-13 16:22:54 -060042do_write_config[deptask] += "do_unpack"