blob: 80089b32e738f2cfdb4c97368459145fe026ce8f [file] [log] [blame]
Patrick Williams1e5b4ec2017-01-30 11:05:56 -06001SUMMARY = "Phosphor DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the phosphor YAML"
3PR = "r1"
4
5S = "${WORKDIR}/git"
6
7inherit autotools pkgconfig
8inherit obmc-phosphor-license
9inherit pythonnative
Marri Devender Rao8dd77982017-05-29 01:33:26 -050010inherit phosphor-dbus-yaml
Patrick Williams1e5b4ec2017-01-30 11:05:56 -060011
12DEPENDS += "autoconf-archive-native"
Brad Bishopc65ac802017-02-02 20:49:22 -050013DEPENDS += "sdbus++-native"
Patrick Williams1e5b4ec2017-01-30 11:05:56 -060014
Patrick Williams1e5b4ec2017-01-30 11:05:56 -060015SRC_URI += "git://github.com/openbmc/phosphor-dbus-interfaces"
Patrick Williamsa456c682017-06-04 20:10:03 -050016SRCREV = "7b54884c0460f529efd047c7c5d1d679c9333a29"
Brad Bishopc65ac802017-02-02 20:49:22 -050017
18DEPENDS_remove_class-native = "sdbus++-native"
19DEPENDS_remove_class-nativesdk = "sdbus++-native"
20
21PACKAGECONFIG ??= "libphosphor_dbus"
Brad Bishop4cf94862017-02-13 14:28:28 -050022PACKAGECONFIG[libphosphor_dbus] = " \
23 --enable-libphosphor_dbus, \
24 --disable-libphosphor_dbus, \
25 systemd sdbusplus, \
26 libsystemd sdbusplus \
27 "
Brad Bishopc65ac802017-02-02 20:49:22 -050028
29PACKAGECONFIG_remove_class-native = "libphosphor_dbus"
30PACKAGECONFIG_remove_class-nativesdk = "libphosphor_dbus"
31
32BBCLASSEXTEND += "native nativesdk"