blob: 5f091e62d8ae67257c443559e031b680e3a88b3c [file] [log] [blame]
Patrick Williams1e5b4ec2017-01-30 11:05:56 -06001SUMMARY = "Phosphor DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the phosphor YAML"
3PR = "r1"
4
5S = "${WORKDIR}/git"
6
7inherit autotools pkgconfig
8inherit obmc-phosphor-license
9inherit pythonnative
10
11DEPENDS += "autoconf-archive-native"
Brad Bishopc65ac802017-02-02 20:49:22 -050012DEPENDS += "sdbus++-native"
Patrick Williams1e5b4ec2017-01-30 11:05:56 -060013
Brad Bishopc65ac802017-02-02 20:49:22 -050014PACKAGE_BEFORE_PN = "${PN}-yaml"
15
16FILES_${PN}-yaml = "${datadir}/${PN}/yaml"
Patrick Williams1e5b4ec2017-01-30 11:05:56 -060017
18SRC_URI += "git://github.com/openbmc/phosphor-dbus-interfaces"
Patrick Williams8a23d842017-02-13 13:20:04 -060019SRCREV = "89c2c18b878e717c354e5a4246f8aa4af20ea588"
Brad Bishopc65ac802017-02-02 20:49:22 -050020
21DEPENDS_remove_class-native = "sdbus++-native"
22DEPENDS_remove_class-nativesdk = "sdbus++-native"
23
24PACKAGECONFIG ??= "libphosphor_dbus"
Brad Bishop4cf94862017-02-13 14:28:28 -050025PACKAGECONFIG[libphosphor_dbus] = " \
26 --enable-libphosphor_dbus, \
27 --disable-libphosphor_dbus, \
28 systemd sdbusplus, \
29 libsystemd sdbusplus \
30 "
Brad Bishopc65ac802017-02-02 20:49:22 -050031
32PACKAGECONFIG_remove_class-native = "libphosphor_dbus"
33PACKAGECONFIG_remove_class-nativesdk = "libphosphor_dbus"
34
35BBCLASSEXTEND += "native nativesdk"