blob: 7258df022baa1604b839e7559a3e9d3cd30da5d8 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001require busybox.inc
2
3SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
4 file://get_header_tar.patch \
5 file://busybox-appletlib-dependency.patch \
6 file://busybox-udhcpc-no_deconfig.patch \
7 file://find-touchscreen.sh \
8 file://busybox-cron \
9 file://busybox-httpd \
10 file://busybox-udhcpd \
11 file://default.script \
12 file://simple.script \
13 file://hwclock.sh \
14 file://mount.busybox \
15 file://syslog \
16 file://syslog-startup.conf \
17 file://syslog.conf \
18 file://busybox-syslog.default \
19 file://mdev \
20 file://mdev.conf \
21 file://mdev-mount.sh \
22 file://umount.busybox \
23 file://defconfig \
24 file://busybox-syslog.service.in \
25 file://busybox-klogd.service.in \
26 file://fail_on_no_media.patch \
27 file://run-ptest \
28 file://inetd.conf \
29 file://inetd \
30 file://login-utilities.cfg \
31 file://recognize_connmand.patch \
32 file://busybox-cross-menuconfig.patch \
Patrick Williamsf1e5d692016-03-30 15:21:19 -050033 file://0001-Switch-to-POSIX-utmpx-API.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034 file://0001-ifconfig-fix-double-free-fatal-error-in-INET_sprint.patch \
35 file://0001-chown-fix-help-text.patch \
Patrick Williamsf1e5d692016-03-30 15:21:19 -050036 file://0001-Use-CC-when-linking-instead-of-LD-and-use-CFLAGS-and.patch \
37 file://0002-Passthrough-r-to-linker.patch \
38 file://0001-randconfig-fix.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039 file://mount-via-label.cfg \
40 file://sha1sum.cfg \
41 file://sha256sum.cfg \
42 file://getopts.cfg \
43"
44
45SRC_URI[tarball.md5sum] = "7925683d7dd105aabe9b6b618d48cc73"
46SRC_URI[tarball.sha256sum] = "05a6f9e21aad8c098e388ae77de7b2361941afa7157ef74216703395b14e319a"
47
48EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
49
50do_install_ptest () {
51 cp -r ${B}/testsuite ${D}${PTEST_PATH}/
52 cp ${B}/.config ${D}${PTEST_PATH}/
53 ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
54}