blob: 303026ad78948764b50e1fa72b8b87867b203b66 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Wrapper script for the Linux kernel module dependency indexer"
2LICENSE = "MIT"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003
4S = "${WORKDIR}"
5
6INHIBIT_DEFAULT_DEPS = "1"
7# The kernel and the staging dir for it is machine specific
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10# We need the following for the sstate code to process the wrapper
11SSTATE_SCAN_FILES += "depmodwrapper"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012EXTRA_STAGING_FIXMES += "PKGDATA_DIR"
13
Brad Bishop316dfdd2018-06-25 12:45:53 -040014DEPENDS += "kmod-native"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015do_populate_sysroot[depends] = ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016
17do_install() {
18 install -d ${D}${bindir_crossscripts}/
19
20 cat > ${D}${bindir_crossscripts}/depmodwrapper << EOF
21#!/bin/sh
22# Expected to be called as: depmodwrapper -a KERNEL_VERSION
23if [ "\$1" != "-a" -o "\$2" != "-b" ]; then
24 echo "Usage: depmodwrapper -a -b rootfs KERNEL_VERSION" >&2
25 exit 1
26fi
Brad Bishop316dfdd2018-06-25 12:45:53 -040027
28kernelabi=""
29if [ -r "${PKGDATA_DIR}/kernel-depmod/kernel-abiversion" ]; then
30 kernelabi=\$(cat "${PKGDATA_DIR}/kernel-depmod/kernel-abiversion")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050031fi
32
Patrick Williamsde0582f2022-04-08 10:23:27 -050033if [ ! -e "\$3${nonarch_base_libdir}/depmod.d/exclude.conf" ]; then
34 mkdir -p "\$3${nonarch_base_libdir}/depmod.d"
35 echo "exclude .debug" > "\$3${nonarch_base_libdir}/depmod.d/exclude.conf"
36fi
37
Brad Bishop316dfdd2018-06-25 12:45:53 -040038if [ ! -r ${PKGDATA_DIR}/kernel-depmod/System.map-\$4 ] || [ "\$kernelabi" != "\$4" ]; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039 echo "Unable to read: ${PKGDATA_DIR}/kernel-depmod/System.map-\$4" >&2
Patrick Williamsde0582f2022-04-08 10:23:27 -050040 exec env depmod -C "\$3${nonarch_base_libdir}/depmod.d" "\$1" "\$2" "\$3" "\$4"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050041else
Patrick Williamsde0582f2022-04-08 10:23:27 -050042 exec env depmod -C "\$3${nonarch_base_libdir}/depmod.d" "\$1" "\$2" "\$3" -F "${PKGDATA_DIR}/kernel-depmod/System.map-\$4" "\$4"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050043fi
44EOF
45 chmod +x ${D}${bindir_crossscripts}/depmodwrapper
46}
47
Patrick Williamsc0f7c042017-02-23 20:41:17 -060048SYSROOT_DIRS += "${bindir_crossscripts}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050049
Brad Bishop316dfdd2018-06-25 12:45:53 -040050PACKAGES = ""
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050051inherit nopackages