Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Perl module to manipulate and access URI strings" |
| 2 | DESCRIPTION = "This package contains the URI.pm module with friends. \ |
| 3 | The module implements the URI class. URI objects can be used to access \ |
| 4 | and manipulate the various components that make up these strings." |
| 5 | |
| 6 | HOMEPAGE = "http://search.cpan.org/dist/URI/" |
| 7 | SECTION = "libs" |
| 8 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 9 | |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c453e94fae672800f83bc1bd7a38b53f" |
| 11 | |
| 12 | DEPENDS += "perl" |
| 13 | |
| 14 | SRC_URI = "http://www.cpan.org/authors/id/E/ET/ETHER/URI-${PV}.tar.gz" |
| 15 | |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 16 | SRC_URI[md5sum] = "cdbbf8f8ccdec5c162c8505077a35c2c" |
| 17 | SRC_URI[sha256sum] = "7e2c6fe3b1d5947da334fa558a96e748aaa619213b85bcdce5b5347d4d26c46e" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | |
| 19 | S = "${WORKDIR}/URI-${PV}" |
| 20 | |
| 21 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}" |
| 22 | |
| 23 | inherit cpan ptest-perl |
| 24 | |
| 25 | do_compile() { |
| 26 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 27 | cpan_do_compile |
| 28 | } |
| 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | do_install:prepend() { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 31 | # these tests require "-T" (taint) command line option |
| 32 | rm -rf ${B}/t/cwd.t |
| 33 | rm -rf ${B}/t/file.t |
| 34 | } |
| 35 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 36 | RDEPENDS:${PN} += "perl-module-integer perl-module-mime-base64" |
| 37 | RDEPENDS:${PN}-ptest += " \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 38 | libtest-needs-perl \ |
| 39 | perl-module-test-more \ |
| 40 | perl-module-test \ |
| 41 | perl-module-utf8 \ |
| 42 | perl-module-extutils-makemaker \ |
| 43 | perl-module-net-domain \ |
| 44 | perl-module-encode \ |
| 45 | perl-module-extutils-mm-unix \ |
| 46 | perl-module-file-spec-functions \ |
| 47 | perl-module-perlio \ |
| 48 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 49 | |
| 50 | BBCLASSEXTEND = "native" |