blob: 0b58a027f34cd2df0020c19e3a054421e4d51bbf [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Dummy package which ensures perl is excluded from buildtools"
2LICENSE = "MIT"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003
Patrick Williamsf1e5d692016-03-30 15:21:19 -05004inherit allarch
Patrick Williamsc124f4f2015-09-15 14:41:29 -05005
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05006PR = "r2"
Patrick Williamsf1e5d692016-03-30 15:21:19 -05007
8python() {
9 # Put the package somewhere separate to ensure it's never used except
10 # when we want it
11 # (note that we have to do this in anonymous python here to avoid
12 # allarch.bbclass disabling itself)
13 d.setVar('PACKAGE_ARCH', 'buildtools-dummy-${SDKPKGSUFFIX}')
14}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015
16PERLPACKAGES = "nativesdk-perl \
17 nativesdk-perl-module-file-path"
18
19ALLOW_EMPTY_${PN} = "1"
20
21python populate_packages_prepend() {
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050022 d.appendVar(d.expand('RPROVIDES_${PN}'), '${PERLPACKAGES}')
23 d.appendVar(d.expand('RCONFLICTS_${PN}'), '${PERLPACKAGES}')
24 d.appendVar(d.expand('RREPLACES_${PN}'), '${PERLPACKAGES}')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025}
26