blob: 103198487b25f4c36f36d544435bc6c38779e762 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001require rsync.inc
2
3SRC_URI += "file://makefile-no-rebuild.patch"
4
5SRC_URI[md5sum] = "0f758d7e000c0f7f7d3792610fad70cb"
6SRC_URI[sha256sum] = "ecfa62a7fa3c4c18b9eccd8c16eaddee4bd308a76ea50b5c02a5840f09c0a1c2"
7
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008# GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0)
9LICENSE = "GPLv3+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
11
12PACKAGECONFIG ??= "acl attr \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060014"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050015PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
16PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
17
18# By default, if crosscompiling, rsync disables a number of
19# capabilities, hardlinking symlinks and special files (i.e. devices)
20CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes"
21
22# rsync 3.0 uses configure.sh instead of configure, and
23# makefile checks the existence of configure.sh
24do_configure_prepend () {
25 rm -f ${S}/configure ${S}/configure.sh
26}
27
28do_configure_append () {
29 cp -f ${S}/configure ${S}/configure.sh
30}
31
32BBCLASSEXTEND = "native"