blob: 5baaf351e1877187e9f829061186db7061bfec7b [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# Copyright (C) 2010 Intel Corporation
3#
4
5SUMMARY = "Linux Standard Base (LSB)"
6DESCRIPTION = "Packages required to satisfy the Linux Standard Base (LSB) specification"
7PR = "r10"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
9inherit packagegroup distro_features_check
10
11# The libxt, libxtst and others require x11 in DISTRO_FEATURES
12REQUIRED_DISTRO_FEATURES = "x11"
13
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014# libglu needs virtual/libgl, which requires opengl in DISTRO_FEATURES
15REQUIRED_DISTRO_FEATURES += "opengl"
16
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017#
18# We will skip parsing this packagegeoup for non-glibc systems
19#
20python __anonymous () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021 if d.getVar('TCLIBC') != "glibc":
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022 raise bb.parse.SkipPackage("incompatible with %s C library" %
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023 d.getVar('TCLIBC'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024}
25
26PACKAGES = "\
27 packagegroup-core-lsb \
28 packagegroup-core-sys-extended \
29 packagegroup-core-db \
30 packagegroup-core-perl \
31 packagegroup-core-python \
32 packagegroup-core-tcl \
33 packagegroup-core-lsb-misc \
34 packagegroup-core-lsb-core \
35 packagegroup-core-lsb-perl \
36 packagegroup-core-lsb-python \
37 packagegroup-core-lsb-desktop \
38 packagegroup-core-lsb-runtime-add \
39 "
40
41
42RDEPENDS_packagegroup-core-lsb = "\
43 packagegroup-core-sys-extended \
44 packagegroup-core-db \
45 packagegroup-core-perl \
46 packagegroup-core-python \
47 packagegroup-core-tcl \
48 packagegroup-core-lsb-misc \
49 packagegroup-core-lsb-core \
50 packagegroup-core-lsb-perl \
51 packagegroup-core-lsb-python \
52 packagegroup-core-lsb-desktop \
53 packagegroup-core-lsb-runtime-add \
54 "
55
56
57RDEPENDS_packagegroup-core-sys-extended = "\
58 curl \
59 dhcp-client \
60 hdparm \
61 lighttpd \
62 libaio \
63 lrzsz \
64 lzo \
65 mc \
66 mc-fish \
67 mc-helpers \
68 mc-helpers-perl \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050069 mdadm \
70 minicom \
71 neon \
72 parted \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050073 quota \
74 screen \
75 setserial \
76 sysstat \
77 udev-extraconf \
78 unzip \
79 watchdog \
80 wget \
81 which \
82 xinetd \
83 zip \
84 "
85
86RDEPENDS_packagegroup-core-db = "\
87 db \
88 sqlite3 \
89 "
90
91RDEPENDS_packagegroup-core-perl = "\
92 gdbm \
93 perl \
94 zlib \
95 "
96
97
98RDEPENDS_packagegroup-core-python = "\
99 expat \
100 gdbm \
101 gmp \
102 ncurses \
103 openssl \
104 python \
105 readline \
106 zip \
107 "
108
109RDEPENDS_packagegroup-core-tcl = "\
110 tcl \
111 "
112
113# Miscellaneous packages required by LSB (or LSB tests)
114RDEPENDS_packagegroup-core-lsb-misc = "\
115 chkconfig \
116 gettext \
117 gettext-runtime \
118 groff \
119 lsbinitscripts \
120 lsbtest \
121 lsof \
122 strace \
123 libusb1 \
124 usbutils \
125 rpm \
126 "
127
128SUMMARY_packagegroup-core-lsb-core = "LSB Core"
129DESCRIPTION_packagegroup-core-lsb-core = "Packages required to support commands/libraries \
130 specified in the LSB Core specification"
131RDEPENDS_packagegroup-core-lsb-core = "\
132 at \
133 bash \
134 bc \
135 binutils \
136 binutils-symlinks \
137 coreutils \
138 cpio \
139 cronie \
140 cups \
141 diffutils \
142 ed \
143 glibc-utils \
144 elfutils \
145 file \
146 findutils \
147 fontconfig-utils \
148 foomatic-filters \
149 gawk \
150 ghostscript \
151 grep \
152 gzip \
153 localedef \
154 lsb \
155 m4 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500156 make \
157 man \
158 man-pages \
159 mktemp \
160 msmtp \
161 patch \
162 pax \
163 procps \
164 psmisc \
165 sed \
166 shadow \
167 tar \
168 time \
169 util-linux \
170 xdg-utils \
171 \
172 glibc \
173 libgcc \
174 libpam \
175 libxml2 \
176 ncurses \
177 zlib \
178 nspr \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500179 nss \
180"
181
182SUMMARY_packagegroup-core-lsb-perl = "LSB Runtime Languages (Perl)"
183DESCRIPTION_packagegroup-core-lsb-perl = "Packages required to support libraries \
184 specified in the LSB Runtime languages specification (Perl parts)"
185RDEPENDS_packagegroup-core-lsb-perl = "\
186 perl \
187 perl-modules \
188 perl-misc \
189 perl-pod \
190 perl-dev \
191 perl-doc \
192"
193
194SUMMARY_packagegroup-core-lsb-python = "LSB Runtime Languages (Python)"
195DESCRIPTION_packagegroup-core-lsb-python = "Packages required to support libraries \
196 specified in the LSB Runtime languages specification (Python parts)"
197RDEPENDS_packagegroup-core-lsb-python = "\
198 python \
199 python-modules \
200 python-misc \
201"
202
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500203SUMMARY_packagegroup-core-lsb-desktop = "LSB Desktop"
204DESCRIPTION_packagegroup-core-lsb-desktop = "Packages required to support libraries \
205 specified in the LSB Desktop specification"
206RDEPENDS_packagegroup-core-lsb-desktop = "\
207 libxt \
208 libxxf86vm \
209 libdrm \
210 libglu \
211 libxi \
212 libxtst \
213 libx11-locale \
214 xorg-minimal-fonts \
215 gdk-pixbuf-loader-ico \
216 gdk-pixbuf-loader-bmp \
217 gdk-pixbuf-loader-ani \
218 gdk-pixbuf-xlib \
219 liberation-fonts \
220 gtk+ \
221 atk \
222 libasound \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500223"
224
225RDEPENDS_packagegroup-core-lsb-runtime-add = "\
226 ldd \
227 pam-plugin-wheel \
228 e2fsprogs-mke2fs \
229 mkfontdir \
230 liburi-perl \
231 libxml-parser-perl \
232 libxml-perl \
233 libxml-sax-perl \
234 glibc-localedatas \
235 glibc-gconvs \
236 glibc-charmaps \
237 glibc-binaries \
238 glibc-localedata-posix \
239 glibc-extra-nss \
240 glibc-pcprofile \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500241"