blob: a5179db1dabea7525175002ef001b316b870e6f1 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "cross-platform C library to defer selection of GL API and of window system"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4c5154407c2490750dd461c50ad94797 \
4 file://include/waffle/waffle.h;endline=24;md5=61dbf8697f61c78645e75a93c585b1bf"
5
6SRC_URI = "http://waffle-gl.org/files/release/${BPN}-${PV}/${BPN}-${PV}.tar.xz \
7 file://0001-third_party-threads-Use-PTHREAD_MUTEX_RECURSIVE-by-d.patch \
8 "
9SRC_URI[md5sum] = "c669c91bf2f7e13a5d781c3dbb30fd8c"
10SRC_URI[sha256sum] = "d2c096cf654bf0061323a4b9231a1ef5b749a1e5c7c5bfe067e964219c2a851c"
11
12UPSTREAM_CHECK_URI = "http://www.waffle-gl.org/releases.html"
13
14inherit cmake distro_features_check lib_package
15
16# This should be overridden per-machine to reflect the capabilities of the GL
17# stack.
18PACKAGECONFIG ??= "glx"
19
20# libx11 requires x11 in DISTRO_FEATURES.
21REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'glx', 'x11', '', d)}"
22
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023# virtual/libgl requires opengl in DISTRO_FEATURES.
24REQUIRED_DISTRO_FEATURES += "${@bb.utils.contains('DEPENDS', 'virtual/${MLPREFIX}libgl', 'opengl', '', d)}"
25
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050026# I say virtual/libgl, actually wants gl.pc
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027PACKAGECONFIG[glx] = "-Dwaffle_has_glx=1,-Dwaffle_has_glx=0,virtual/${MLPREFIX}libgl libx11"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050028
29# I say virtual/libgl, actually wants wayland-egl.pc, egl.pc, and the wayland
30# DISTRO_FEATURE.
Brad Bishop6e60e8b2018-02-01 10:27:11 -050031PACKAGECONFIG[wayland] = "-Dwaffle_has_wayland=1,-Dwaffle_has_wayland=0,virtual/${MLPREFIX}libgl wayland"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050032
33# I say virtual/libgl, actually wants gbm.pc egl.pc
Brad Bishop6e60e8b2018-02-01 10:27:11 -050034PACKAGECONFIG[gbm] = "-Dwaffle_has_gbm=1,-Dwaffle_has_gbm=0,virtual/${MLPREFIX}libgl udev"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050035
36# I say virtual/libgl, actually wants egl.pc
Brad Bishop6e60e8b2018-02-01 10:27:11 -050037PACKAGECONFIG[x11-egl] = "-Dwaffle_has_x11_egl=1,-Dwaffle_has_x11_egl=0,virtual/${MLPREFIX}libgl libxcb"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050038
39FILES_${PN}-dev += "${datadir}/cmake/Modules/FindWaffle.cmake \
40 ${libdir}/cmake/Waffle/"